none
BizTalk 2010 TIBCO Rendezvous adapter error? RRS feed

  • Question

  • Hi All,

    I am trying to configure TIBCO Rendezvous adapter for Biztalk 2010 and get the following errors in event log.


    1. A Rendezvous service process was started, but failed during initialization.  Runtime error message: File or assembly name TIBCO.Rendezvous, or one of its dependencies, was not found.. If you are using a different version of Tibco Rendezvous try changing assembly binding in mbaRV.exe config.


    I am using version 1.0.2862.35699 for Tibco.Rendezvous.dll. I made sure that rvd service was running. Also gave path for the tibco files in the transport properties and in the PATH. Use dependency walker and it didnt find dwmap.dll. So i put dwmap.dll in the same folder as Tibco dll. Still the error is not resolved. I am using Tibco RV 8.0


    2.Details:"The Messaging Engine failed while notifying an adapter of its configuration. ".

    When i send a message using the TIBCO SDK, the Receive Location is disabled and logs the above message in the event viewer. Have no clue why its failing. The tranport properties seem to be pretty straighfwd. I entered the Subject name, left the deamon,service,network as default(blank).I also tried putting in 7500,tcp:7500 but that didnt make any difference.


    3.Occasionaly I get the message in event viewer that the key corresponding to receive location is already added in the hashtable.


    4. Changed the receive handler to BizTalkServerApplication. MSDN says it should Isolation Host but that option is not provided after installation.


    Any clues or info would be appreciated.

    Wednesday, July 20, 2011 11:16 AM

All replies

  • Verify you have the TIBCO Rendezvous Runtime Component installed on your computer. The Runtime Component is the only component that you must install when you install TIBCO Rendezvous.

    At a Visual Studio command prompt, change directories to the location of the TIBCO.Rendezvous.dll file. The path of this DLL in the default installation of TIBCO Rendezvous is C:\TIBCO\TIBRV\BIN\TIBCO.Rendezvous.dll.

    At the command prompt, type the following:

    C:\TIBCO\TIBRV\BIN > gacutil /i TIBCO.Rendezvous.dll

    The TIBCO.Rendezvous.dll now shows GAC list. To view the list, in Control Panel, open Administrator Tools, open Microsoft .NET Framework Configuration, and then open Assembly Cache.

    http://download.microsoft.com/download/E/2/C/E2CE7633-5324-4A97-94E5-C689BBA3ECCF/Installation%20Guide.htm#ID0ER1BG


    Thanks, Raja
    Wednesday, July 20, 2011 11:42 AM
  • Hi vaibhavtiwari ,

    for you second Question I have good solution

    as you told Receive Location is disabled this happens when you do not give write permisions for the folder your using...............

    see the Folder properties........>Security tab.........> see edit there..........> tick the checkbox of full control.

    Then only this problem will be solved.

    Thanks,

    Rajesh

    Wednesday, July 20, 2011 11:53 AM
  • Hi,

    Thanks for the answers Guys, but unfortunately, I have tried the suggetions but they doesn't seem to work in my case. Also does anyone know how to modify mbaRV.exe.config file to change the version of TIBCO.Rendezvous.dll that BizTalk is refering to?

    Thanks

    Vaibhav



    Wednesday, July 20, 2011 1:26 PM
  • On the surface if you are going to have to change the Tibco config files to change the version of the Tibco files you are using, sounds like a versioning mismatch of the Tibco product.  I would suggest getting ahold of Tibco and obtaining the latest adapter and using that.
    Wednesday, July 20, 2011 1:29 PM
  • This is the exact error message which I am getting:

    A Rendezvous service process was started, but failed during initialization. Runtime error message: Could not load file or assembly 'TIBCO.Rendezvous, Version=1.0.3036.23330, Culture=neutral, PublicKeyToken=1a696d1f90f6158a' or one of its dependencies. The system cannot find the file specified.. If you are using a different version of Tibco Rendezvous try changing assembly binding in mbaRV.exe config.

    Wednesday, July 20, 2011 3:39 PM
  • I would place a call into the Tibco support team, maybe they pulished a bad version of the adapter, would not be the first time that I have run into that situation.
    Wednesday, July 20, 2011 3:41 PM
  • Jason,

    I guess it is BizTalk adapter that is trying to get a different version of TIBCO.Rendevous.dll, Not sure how to change the bindings for mbaRV.config.exe file.

    Thanks

    Vaibhav

    Wednesday, July 20, 2011 3:44 PM