none
"Error 1001. Unable to get installer types in the <install path>\Small Basic\SB.exe assembly" when installing Small Basic 0.6 RRS feed

  • Question

  • I am trying to install Small Basic 0.6.  On Windows XP.  I have the .Net framework 3.5sp1 installed.  I had Small Basic 0.3 installed.  I ran the installer to see if it would upgrade, and it didn't work.  I uninstalled Small Basic, and then ran the installed for 0.6.  Every time I run the installer, it looks like it's working, then near the end I get this:

    Error 1001. Unable to get installer types in the C:\Program Files\Microsoft\Small Basic\SB.exe assembly. --> Unable to load one or more of the requested types.  Retrieve the LoaderExceptions property for more information.
    Saturday, September 5, 2009 2:47 AM

Answers

  • TonyBye,

    The upgrade scenario from v0.3 is untested and likely to have issues with left over assemblies.  Can you please do an uninstall first and then delete the directory "c:\program files\microsoft\smallbasic" and then install v0.6?

    • Proposed as answer by litdevModerator Tuesday, September 15, 2009 8:41 PM
    • Marked as answer by TonyBye Monday, September 21, 2009 2:13 AM
    Sunday, September 6, 2009 5:33 PM
    Moderator

All replies

  • TonyBye,

    The upgrade scenario from v0.3 is untested and likely to have issues with left over assemblies.  Can you please do an uninstall first and then delete the directory "c:\program files\microsoft\smallbasic" and then install v0.6?

    • Proposed as answer by litdevModerator Tuesday, September 15, 2009 8:41 PM
    • Marked as answer by TonyBye Monday, September 21, 2009 2:13 AM
    Sunday, September 6, 2009 5:33 PM
    Moderator
  • Thanks!  That worked.  I didn't realize I had to delete that directory after uninstalling.
    Monday, September 21, 2009 2:13 AM
  • We had exactly the same problem upgrading from 0.4.
    This solution worked a treat.

    Thank you
    Richard
    Saturday, September 26, 2009 3:23 PM