none
Master Page Updated and now receiving Something Went Wrong

    Question

  • I created a copy of the Seattle master page and added a javascript link in the new master page. Now that I have activated the new master page I receive "Something went wrong error" and I cannot get access to the site to change it back to seattle master page. Every attempt displays the previous error? Any ideas on how to get it back?

    Other info:

    • Created copy of master via Designer 2013
    • Published new master page via Design Manager in SP I think I changed both the site AND admin master page to my new page (that's probably what broke it!)
    • I can get to the top level site collection page

    Thanks for your help!

    Thursday, December 8, 2016 11:03 PM

Answers

  • Just to clarify for those who read this later, in SP Designer 2013, I selected Master Pages from the left navigation column, and Right clicked on the .master file not the .html file. Then I selected the option to Set As Default. 

    I was unable to find the option on the ribbon bar for some reason.

    Thanks a bunch for your help!!!

    Mike

    • Marked as answer by M_Aleman Friday, December 9, 2016 10:59 AM
    Friday, December 9, 2016 10:59 AM

All replies

  • Hi M_Aleman,

    There are two ways to change the master page back.

    >> Specify the master page to be used by site in SharePoint designer.

    1. Open site in SharePoint Designer, click on “Master Pages” on the left navigation.

    3. Select seattle master page, and then set it as Default and Custom master page.


    >> Change the master page to be used by sites in the site collection level.

    1. Go to top level Site Collection.

    2. Navigate to the Site Settings page, click on “Master Page” under “Look and Feel” section

    3. Check “Reset all subsites to inherit this site master page setting”.


    Best regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, December 9, 2016 6:50 AM
    Moderator
  • Just to clarify for those who read this later, in SP Designer 2013, I selected Master Pages from the left navigation column, and Right clicked on the .master file not the .html file. Then I selected the option to Set As Default. 

    I was unable to find the option on the ribbon bar for some reason.

    Thanks a bunch for your help!!!

    Mike

    • Marked as answer by M_Aleman Friday, December 9, 2016 10:59 AM
    Friday, December 9, 2016 10:59 AM