none
Speech not working outside IDE RRS feed

  • Question

  • Hi there,

    I'm developing my college project using the Kinect and Speech SDK. However, I've only just recently started trying to package up the application and try running it outside of the IDE. If I run the application inside Visual Studio C#, it works no problem. My commands get recognised, and the program functions as expected.

    However, if I try to run the application outside of the IDE, speech commands just refuse to work. From what I can tell, not a single error is being thrown anywhere. I've tested other speech applications, and they work fine. Am I missing something? The code looks fine, unless there's some function I should be aware of that will function differently outside of the IDE. I can't see anything wrong whatsoever.

    Thanks for the help!

    Tuesday, May 1, 2012 3:11 PM

All replies

  • There shouldn't be any APIs that function differently when running under the debugger vs. not running under the debugger.

    A couple of quick questions:

    1) Have you tried running release mode under the debugger and seeing if it functions correctly?

    2) Have you tried attaching to the running process that was started outside the debugger (I recommend building w/ symbols to make this easier) and seeing the state of the various speech objects?  It may be that some initialization thing is busted, but not caught correctly.

    3) Do other speech applications (e.g. speech enabled apps from the toolkit like ShapeGame) work for you outside the debugger?

    Tuesday, May 1, 2012 6:53 PM