locked
Biztalk Schemas Published as WCF Service WSHTTP Binding RRS feed

  • Question

  • Hi,

    I have Published my Schemas using BizTalk WCF Publishing wizard using WCF-WSHTTP Binding. Bu Default the security is Message .

    when I create a client and sedn the request its working fine.

    but when I invoke this service in Soap UI, and send the message I am getting an error like

    The message could not be processed. This is most likely because the action ''is incorrect or because the message contains an invalid or expired security context token or because there is a mismatch between bindings. The security context token would be invalid if the service aborted the channel due to inactivity. To prevent the service from aborting idle sessions prematurely increase the Receive timeout on the service endpoint's binding.

    so when I try to disable the Security in the recive location to none its not working either at the client or as well at the server I get the error saying '' Finding the document specification by message type "Http:Schemas.xml.soap.org////trust#RequestSecurityToen Failed"

    Can you help me how to disable security check and make it work at the Soap UI as well as at any client?

    Tuesday, November 17, 2015 9:59 AM

Answers

  • Hi Sujith ,

    When you are hitting the service through SOAP UI having  you get exception"

    The message could not be processed. This is most likely because the action ''is incorrect or because the message contains an invalid or expired security context token or because there is a mismatch between bindings. The security context token would be invalid if the service aborted the channel due to inactivity. To prevent the service from aborting idle sessions prematurely increase the Receive timeout on the service endpoint's binding"

    This happens because SOAPUI doesn’t appear to support this setting, you will need to turn it off while you are testing from SOAPUI or use an alternative testing tool."

    Well described here https://adventuresinsidethemessagebox.wordpress.com/2012/10/22/calling-a-wcf-wshttp-service-from-soapui/ 

    Thanks

    Abhishek


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply

    Wednesday, November 18, 2015 8:42 AM

All replies

  • If you don't want to use security feature, then why don't you select WCF-BasicHttp instead of WCF-WSHTTP when you publish Biztalk schema.

    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer



    Tuesday, November 17, 2015 10:20 AM
  • Or you can change the generated receive location to use WCF-Custom and set Security->Mode to None and Security->Transport->clientCredentialType to None

    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer

    Tuesday, November 17, 2015 11:10 AM
  • Hi Sujith ,

    When you are hitting the service through SOAP UI having  you get exception"

    The message could not be processed. This is most likely because the action ''is incorrect or because the message contains an invalid or expired security context token or because there is a mismatch between bindings. The security context token would be invalid if the service aborted the channel due to inactivity. To prevent the service from aborting idle sessions prematurely increase the Receive timeout on the service endpoint's binding"

    This happens because SOAPUI doesn’t appear to support this setting, you will need to turn it off while you are testing from SOAPUI or use an alternative testing tool."

    Well described here https://adventuresinsidethemessagebox.wordpress.com/2012/10/22/calling-a-wcf-wshttp-service-from-soapui/ 

    Thanks

    Abhishek


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply

    Wednesday, November 18, 2015 8:42 AM