none
Error when I run the IOT examle RRS feed

  • Question

  • Hi all,

    I get the error below when I run the IOT hub example in vs2017.

    1>------ Build started: Project: AzureIoT, Configuration: Debug ARM ------
    1>In file included from sample_hardware.h:13,
    1> from main.c:36:
    1>mt3620_rdb.h:10:10: fatal error: ......\mt3620\inc\hw\mt3620.h: No such file or directory
    1> #include "......\mt3620\inc\hw\mt3620.h"
    1> ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    1>compilation terminated.
    1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\VC\VCTargets\Application Type\Linux\1.0\AzureSphere.targets(105,5): error MSB6006: "arm-poky-linux-musleabi-gcc.exe" exited with code 1.
    1>Done building project "AzureIoT.vcxproj" -- FAILED.
    ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

    Thoughts?

    J

    Tuesday, September 10, 2019 9:31 AM

All replies

  • Hi,

    Can you share more details regarding your issue? Which example are you trying? 

    Tuesday, September 10, 2019 11:30 AM
    Moderator
  • @John_13579

    Have you had a chance to see the above response? Please share more details regarding your issue.

    Wednesday, September 11, 2019 11:48 AM
    Moderator
  • From your output it looks like VS2017 can't find the "......\mt3620\inc\hw\mt3620.h" file.  The Microsoft examples use a higher level hardware folder to store all the hardware specific header files.  When you clone the examples project, you must pull the hardware directory or you'll get an error like you're seeing.  The easiest way to do this is to just pull the entire repo from: https://github.com/Azure/azure-sphere-samples.git.

    Hope this helps!

    Wednesday, September 11, 2019 2:28 PM
  • Hi,

    I'm using the IOT example from github, I'll try the entire repro as before I pulled the 'entire' example, but as you say that could still be missing something. Will give it a go tonight.

    Thanks

    J


    Monday, September 16, 2019 10:46 PM
  • Please try the suggestions provided above and let us k now if you need further help.
    Wednesday, September 18, 2019 4:59 AM
    Moderator