locked
Reason: Invalid login information RRS feed

  • Question

  • I can log in to a database with administrator account, but not with an user account.

    I am getting "Invalid login information" error message.  What will be the likely cause for this?

    I am using Winodws authentication.

    Tuesday, March 25, 2008 9:44 PM

Answers

  • You cannot remove public, However If you have logged in with a user id that is either a sysadmin to security admin then you can add the user to a db_creator role too.

    Satheesh
    My Blog


    Sunday, January 19, 2014 5:14 AM
    Answerer

All replies

  • Assure that the active directory or computer acount has been added to the instance of sql server for a log in.  Go to :

    1. SSMS object browser

    2. Open the Security folder

    3. Open the Logins folder

    4. Assure that the user or group is within the folder

    5. Go to the user database Secuirty folder

    6. Open the Users folder

    7. Assure that there is a user that is mapped back to the sql login 

     

    If the login or user is not present you can add them by right clicking on the appropriate folder and choosing Add Login/User.

     

    You can also use DCL t-sql statement to do this.  BOL lists the syntax under CREATE LOGIN.

     

    Code Snippet

    CREATE LOGIN [domain\Administrator] FROM WINDOWS WITH DEFAULT_DATABASE=[master], DEFAULT_LANGUAGE=[us_english]

     

    CREATE USER [Administrator] FOR LOGIN [domain\Administrator] WITH DEFAULT_SCHEMA=[dbo]

     

     

    Tuesday, March 25, 2008 11:52 PM
  • According to your instruction, I checked for an user login setting.  The user accout was there already.  From the user's cmd window, I typed, sqlcmd -E -Spl-ptsvr\sqlexpress, but I got 'Msg 18456, Level 14, State 1, Server PL-PTSVR\SQLEXPRESS, Line 1
    Login failed for user'. 

    Is there anything else that might be causing a problem?

     

    By the way, in Server Roles for any user, I have a check mark on 'public', and I can't remove it. 
    I want to assign this user 'dbcreator'.  How can I remove the check mark?
    (SSMS PL-PTSVR\SQLEXPRESS>Security>Logins>Login Properties>Server Roles)

     

    Thank you,

     

    Wednesday, March 26, 2008 4:01 PM
  • Caitac,

    Is this still an issue?

    Thanks!


    Ed Price, Power BI & SQL Server Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    Sunday, January 19, 2014 1:48 AM
  • You cannot remove public, However If you have logged in with a user id that is either a sysadmin to security admin then you can add the user to a db_creator role too.

    Satheesh
    My Blog


    Sunday, January 19, 2014 5:14 AM
    Answerer