locked
How to set Mandatory Choice field while Creating Custom Task using Sharepoint Designer 2007 RRS feed

  • Question

  • Hi,

    I am new to Sharepoint development.I dont know whether i am posting  the question in Correct place.Kindly redirect me to the correct place if i am posting it in wrong place.
    I  created a custom task in Sharepoint Designer 2007 using Collect Data from User Action.
    I created a field in the task form which is of choice type and unchecked allow blank values because i  wanted that field to be a mandatory field.When i handled that task ,i was able to complete that task without selecting that mandatory field.But, I was expecting not to allow me to complete the task without selecting that field. Kindly  tell me how to set the choice field as mandatory.

    • Moved by tonysoper_MSFT Friday, July 15, 2011 4:46 PM wrong forum (From:TechNet Wiki Discussion)
    • Moved by Xue-Mei Chang-MSFTModerator Tuesday, July 19, 2011 6:04 AM SPD 2007 issue (From:SharePoint 2010 - General Questions and Answers)
    Thursday, July 14, 2011 9:37 AM

All replies

  • Hi,

     

    You are using SharePoint Designer 2007, so I moved the thread to the appropriate forum for MOSS 2007.

     

    This is by design that Workflow-generated form (for action Collect data from User) does not perform validation properly on drop-down choices, the workaround is to use JavaScript to perform the field validation.

     

    This thread has the JavaScript code can help you: http://social.msdn.microsoft.com/forums/en-US/sharepointworkflow/thread/0ad7fc3c-97a1-464e-ae89-c3133462dda8/


    Xue-Mei Chang
    • Edited by Mike Walsh FIN Tuesday, July 19, 2011 6:31 AM queue (wrong word) changed to "the appropriate forum" (well spotted that this doesn't go to General)
    Tuesday, July 19, 2011 6:23 AM
    Moderator
  • "by design" ??  If that is the case then why is the check box for 'Allow blank values' even there?

    Seems like 'poor design'.


    ja

    Thursday, July 25, 2013 6:55 PM
  • I agree with Jeff1929.  I spent hours, unchecking the Allow blank values, republishing only to find it checked every time I try to check the setting.  Should be hidden or grayed out at least.

    Herschel

    Friday, March 28, 2014 3:59 PM