Error returned Data overflow converting to the data type RRS feed

  • Question

  • Hi, I am having a problem with SSAS Tabular when I tried to import data from data sources.

    The title says it all.

    The error message: Failed to save modifications to the server. Error returned: 'Data overflow converting to the data type for table X column Y'

    I tried to remove the column with filter, but my supervisor asked me not to because it's needed.

    SSAS is pretty new in my office and no one mastered it, any kind of help is appreciated.

    Wednesday, November 27, 2019 8:41 AM


All replies

  • That means that column Y has been set to a data type that is too small for the data that is being loaded into it. 

    It's impossibly to be more specific without knowing what data type the column is currently set to and what the data type of the source column is.

    This document might help as it lists the data types and the ranges of values that they can store


    http://darren.gosbell.com - please mark correct answers

    Thursday, November 28, 2019 12:48 AM
  • Thank you for your answer. I did a query to the table and found out that one of the row contains date that surpassed the limitation of allowed value. What I did was doing a query with specific condition.
    Monday, December 2, 2019 6:49 AM
  • I had a similar kind of issue for one of my tabular model processing.  The source column was date data type and during the model process it was failed with the below error

    The JSON DDL request failed with the following error: Failed to execute XMLA. Error returned: 'Data overflow converting to the data type for table 'X' column 'Y'.

    I was tried several ways adding removing the column in model and did not fix as the source column was proper date datatype and model datatype also the same.

    The below  MS documentation link clearly says allowable implicit conversion of the data types.


    some valid date ranges fall on below range before (March 1, 1900). was caused the issue and I handled such dates properly and ended the problem.

    Friday, April 24, 2020 6:05 AM