locked
Stream Analytics - no output events RRS feed

  • Question

  • Hi, 

    I have a problem with stream analytics job. Job monitor shows input events (from Event Hub) but there are no output events or errors. Job is really simple, just to write every input to blob storage:

    SELECT * FROM input

    Any suggestions what could be wrong?


    Friday, April 10, 2015 11:54 AM

Answers

  • The fix is now rolled out to Production, please verify that the your job now works. You will have to stop and restart your job.

    Thanks


    Zafar Abbas

    • Marked as answer by Zafar Abbas Saturday, April 11, 2015 5:42 AM
    Saturday, April 11, 2015 5:42 AM

All replies

  • Thanks for reporting.

    This is a known issue and we are deploying a fix shortly.

    Will keep you posted.


    Zafar Abbas

    Friday, April 10, 2015 8:56 PM
  • The fix is now rolled out to Production, please verify that the your job now works. You will have to stop and restart your job.

    Thanks


    Zafar Abbas

    • Marked as answer by Zafar Abbas Saturday, April 11, 2015 5:42 AM
    Saturday, April 11, 2015 5:42 AM
  • Thanks for reply,

    I have two stream analytics jobs with the same input (event hub).

    First job (working)
    Simple query (SELECT * FROM input) and output is properly saved to blob storage. 

    Second job (not working)
    More complex query (count, avg etc.) but no output events or errors. Query is working fine (tested with sampled data from input). 


    Monday, April 13, 2015 3:27 PM
  • I too have a complex job with count, min, avg and max. My job is also not producing any output events to a database.
    Sunday, April 19, 2015 4:03 AM
  • Hello, Does this issue still reproduce for you? We have fixed a bug dealing with Event Hub input where multiple jobs reading from the same input event hub ran into issues. Please restart your job to verify if things are working for you after that fix. Thanks

    Zafar Abbas

    Sunday, April 26, 2015 5:23 PM
  • I believe this issue still persists. I have reported the same issue on a different thread as well. No Power BI output events are being generated. All tests including input, sampling, query test and output test are OK. Dashboard only shows input event activity and no outputs. This has been an issue for over 2 weeks now. Please let me know if there is a fix to this solution because we are unable to demo real time streaming to Power BI capabilities.
    Saturday, June 6, 2015 2:35 PM
  • I am facing this issue as well.

    SELECT * FROM <InputAlias> --> This query produced output

    However, when I used aggregate functions like MIN, MAX, etc. output events are not produced.

    The 'Test' function on query tab which uses test json file works fine though which means the query should be correct. 


    KJ

    Saturday, June 27, 2015 6:18 PM