locked
C++ Metro style app slow to load?

    Question

  • I just ran the default C++ App templates and was disappointed with the performance (startup took multiple seconds - I did not modify the code at all). Did someone else notice this behavior?
    Monday, September 19, 2011 11:53 PM

All replies

  • Slow compared to an equivalent C#/VB or JS metro app?

     

    Did you run it with the debugger? Was the build complete? Many factors here.


    http://blog.voidnish.com
    Tuesday, September 20, 2011 12:19 AM
  • Was the application fully built and deployed before launching the application? Are you launching the app through Ctrl +F5?

    Li Shao, MSFT


    Li Shao
    Tuesday, September 20, 2011 4:32 AM
  • Ok, got it now. Sometimes when I launch the application, It takes forever(crashes). If it starts, it's not that slow < 1 sec. I guess, we are still dealing with preview bits so it should be ok. How do I delete this question?
    Wednesday, September 21, 2011 12:25 PM
  • Ok, got it now. Sometimes when I launch the application, It takes forever(crashes). If it starts, it's not that slow < 1 sec. I guess, we are still dealing with preview bits so it should be ok. How do I delete this question?

    There's no need to delete the question. Resolved threads are left here for posterity.
    http://blog.voidnish.com
    Wednesday, September 21, 2011 12:28 PM
  • Also, please let me know if you consistantly see the crash when launching the app. You can send me email lishao AT microsoft.com.

    Li Shao, MSFT


    Li Shao
    Wednesday, September 21, 2011 5:48 PM