none
Classic ASP, ADO 2.7, x64 on W2K3 RRS feed

  • Question

  • Didn't see exaclyt the right place for this, so I'll take a shot here.

    We have a classic ASP program that depends on MSADO 2.7 that we haven't spent any time trying to update.  Recently we've been trying to move from 32-bit systems to 64-bit ones.  In our dev environment, we got new x64 Windows 7 boxes and things just worked; we didn't give too much thought to it.

    Our operations dept, however, likes to use W2K3 on everything, so when they got a new x64 box they put on W2k3 x64 and the old asp app blew up because it couldn't find MSADO 2.7.

    Looking into it a little, I found that in Windows 7 HKCR\Typelib\{EF53050B-882E-4776-B643-EDA472E8E3F2} (the typelib root for one of the ADO 2.7 classes) existed at the top level of the x64 registry with a win32 subkey - it was not just in the Wow6432Node.  I'm figuring that's what allowed it to work without thought when we set up on W7.

    Looking at the W2k3 x64 box, that typelib is only found under the Wow6432Node.

    So...  1) Why is it different between W7 and W2K3 and 2) What do I need to do in W2k3 to sort it out?  I've tried re-running regsvr32 on the ado dll but it didn't put any entries in the 64-bit visible hive.

    Thanks
    Mark

    Tuesday, October 5, 2010 4:48 PM

Answers