none
my app (based on the SkeletalViewer sample) won't run correctly on some machines RRS feed

  • Question

  • I've started from SkeletalViewer that works fine on my quad core at the office, and my dual core at home, and even runs slowly on my small laptop. But it won't run on several laptops in North Carolina. I'm in California, so that's a problem. It appears to use much more cpu than I'm using when I run the application here. Eventually, the whole computer locks up and has to be power cycled.

    I know this is not much to go on, but does anybody have any idea what might be happening? He is able to run the samples without problems, so it's not that the computers are underpowered. The laptops are high end dual cores, lots of memory.

    Any ideas, or anything I can try? What could cause this?

    Wednesday, May 9, 2012 2:06 AM

Answers

  • Since the sample code works fine on these machines, it would be difficult to know what you have done without seeing your code. What does your code do, compared to that of the samples. Are your issues with rendering or getting the data. Are you following best practices when it comes to processing the data?

    If you are not able to share your code, then I would recommend you open a support case with Microsoft Developer Support and they can work with you directly.

    http://support.microsoft.com/select/?target=assistance

    • Marked as answer by stereosphere Wednesday, May 9, 2012 5:11 PM
    Wednesday, May 9, 2012 4:08 AM

All replies

  • Since the sample code works fine on these machines, it would be difficult to know what you have done without seeing your code. What does your code do, compared to that of the samples. Are your issues with rendering or getting the data. Are you following best practices when it comes to processing the data?

    If you are not able to share your code, then I would recommend you open a support case with Microsoft Developer Support and they can work with you directly.

    http://support.microsoft.com/select/?target=assistance

    • Marked as answer by stereosphere Wednesday, May 9, 2012 5:11 PM
    Wednesday, May 9, 2012 4:08 AM
  • I have some more information from North Carolina: He is getting a message that says 

    This application has requested the Runtime to terminate it in an unusual way

    So this has something to do with his runtime? I'm using Visual Studio 2010 C++.

    I'll put up the relevant code soon.

    Wednesday, May 9, 2012 5:32 PM