none
Sharepoint 2013 Visual Studio Workflow not visible RRS feed

  • Question

  • Hi All.

    I have created a  Visual Studio workflow in a sharepoint hosted app.

    The WF is attached with a custom list (List is also created inside the APP).

    when i deploy the app to sharepoint  it gets deployed successfully with no errors.

    The list is also visible but the associated WF is not visible.

    Can somebody suggest as to what can be the issue.

    Regards

    Tuesday, January 13, 2015 5:54 AM

Answers

All replies

  • As of my understanding 2013 workflow cannot be deployed directly like what we did in 2010.

    In 2013 Administrator approval is required.

    You may noticed that 'Whenever you create a new workflow a feature had been created for the particular workflow'

    We need to activate the feature to enable the workflow.

    Kindly go through this  Link .

    _____________________________________________________

    Please remember to click 'Mark as Answer' on the answer if it helps you

    Regards,

    Sathya


    Tuesday, January 13, 2015 9:58 AM
  • try these links:

    http://www.vrdmn.com/2014/09/integrated-workflow-apps-deploy.html

    http://stackoverflow.com/questions/22345600/visual-studio-2012-wont-deploy-my-sharepoint-2013-workflow-in-an-apphttp://sharepoint.stackexchange.com/questions/73895/visual-studio-2012-not-deploying-sharepoint-2013-workflow

    https://social.msdn.microsoft.com/Forums/sharepoint/en-US/4cb6e358-e024-465c-ab9a-8ecc6d5806be/issue-with-workflow-2013-as-a-sharepoint-app-application?forum=sharepointdevelopment

    Tuesday, January 13, 2015 12:17 PM
  • Hi,

    Please try to install SharePoint 2013 SP1. After doing it run following powershell script on your server:

    $WmsSap = Get-SPWorkflowServiceApplicationProxy
    $WmsSap.RegisterWorkflowLifecycleManagementEnvironment()

    Here is a similar thread for your reference:

    http://stackoverflow.com/questions/22345600/visual-studio-2012-wont-deploy-my-sharepoint-2013-workflow-in-an-app

    Best Regards


    Dennis Guo
    TechNet Community Support


    Wednesday, January 14, 2015 7:03 AM
    Moderator