MDS Database upgrade from 2014 to 2016 fails with timeout RRS feed

  • Question

  • Hello, 

    I've been attempting to update an MDS database to 2016. Every time I run the upgrade wizard, it runs for well over an hour and eventually errors out with the following:

    Microsoft.MasterDataServices.Configuration.ConfigurationException: Timeout expired.  The timeout period elapsed prior to completion of the operation or the server is not responding. ---> System.Data.SqlClient.SqlException: Timeout expired.  The timeout period elapsed prior to completion of the operation or the server is not responding. ---> System.ComponentModel.Win32Exception: The wait operation timed out
       --- End of inner exception stack trace ---
       at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)
       at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose)
       at System.Data.SqlClient.TdsParserStateObject.ReadSniError(TdsParserStateObject stateObj, UInt32 error)
       at System.Data.SqlClient.TdsParserStateObject.ReadSniSyncOverAsync()
       at System.Data.SqlClient.TdsParserStateObject.TryReadNetworkPacket()
       at System.Data.SqlClient.TdsParserStateObject.TryPrepareBuffer()
       at System.Data.SqlClient.TdsParserStateObject.TryReadByte(Byte& value)
       at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady)
       at System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds(String methodName, Boolean async, Int32 timeout, Boolean asyncWrite)
       at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(TaskCompletionSource`1 completion, String methodName, Boolean sendToPipe, Int32 timeout, Boolean asyncWrite)
       at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
       at Microsoft.MasterDataServices.Configuration.DatabaseUtilities.ProcessSqlStringWithTransaction(String commandSql, SqlConnection connection, SqlTransaction upgradeTransaction)
       at Microsoft.MasterDataServices.Configuration.DatabaseUtilities.UpgradeMasterDataServicesDatabase(SqlConnection connection, String databaseName, Collection`1& businessRuleExclusionWarnings)
       at Microsoft.MasterDataServices.Configuration.Commands.UpdateMasterDataServicesDatabase.InternalProcess()
       at Microsoft.MasterDataServices.Configuration.Commands.SqlCmd`1.Execute()
       at Microsoft.MasterDataServices.Configuration.InstanceManager.UpgradeMasterDataServicesDatabase(DatabaseServerInformation serverInformation, DatabaseInformation databaseInformation)
       --- End of inner exception stack trace ---
       at Microsoft.MasterDataServices.Configuration.InstanceManager.UpgradeMasterDataServicesDatabase(DatabaseServerInformation serverInformation, DatabaseInformation databaseInformation)
       at Microsoft.MasterDataServices.Configuration.ConfigurationAdministration.UpgradeDatabase(DatabaseInformation databaseInformation)
       at Microsoft.MasterDataServices.Configuration.UI.MdsDatabase.UpgradeDatabase()

    Note that this is a development instance with no other databases or connections and ample resources. Also, the database was originally 2008, but continuously failed the update so I tried going to 2014 thinking maybe an incremental update may work. The move from 2008 to 2014 took seconds, but I received the same error when attempting to promote to 2014. The SQL installation on this server is 2016 Enterprise SP1. Any ideas would be greatly appreciated!


    Thursday, August 24, 2017 8:02 PM

All replies

  • Were you able to get this resolved?  Running into the same issue.
    Friday, July 26, 2019 1:47 PM
  • Have you been following the steps in this guide?


    There is an imoprtant notice about MDS Application schema upgrade... 



    To upgrade the MDS database schema, you must be logged in as the Administrator Account that was specified when the MDS database was created. In the MDS database, in mdm.tblUser, this user has the ID value of 1.


    You can also try to shutdown the MDS Apllication Pool in IIS to make sure there are no open connection to the DB from IIS...

    This problem might indicate that you have a large number of logged transactions in one or more of your entity tables. As prior version of MDS had no retention period and no automatic clean up of logged transactions.

    Due to the fact that each changed attribute of a member is logged as one row in the log table an entity with lots of inserts/updates might have really big log (*_TR) tables in the MDS database.

    Try rebuilding clustered indexes befor performing the MDS schema upgrade. 



    Friday, August 16, 2019 11:17 AM
  • @mcourcy Did you have the exact same issue? See my reply to @dmosely, does that help you?
    Friday, August 16, 2019 11:21 AM