locked
IIS7, fckeditor and asp RRS feed

  • Question

  • User1915089424 posted

    Hi all,

    I'm trying to use fckeditor (a html wyiswyg editor) with classic asp on an IIS7 environment. The problem is not specific to fckeditor but I think it's involving some iis7 configuration.

    To load the editor, the url is like this one:

    http://www.domain.com/fckeditor/editor/fckeditor.html?InstanceName=Testo&Toolbar=Default

    as you can see there's an html page with a query string. Calling this page gives a 403.14 error, telling that there's no default document configured for that directory. But looking at the error log, I see that the real requested url was:

    http://www.domain.com/fckeditor/editor/?InstanceName=Testo&Toolbar=Default

    the "fckeditor.html" part of the url was cut. Giving that file as default document doesn't solve the problem, as it gives other errors regarding the editor itself.

    I think that maybe iis7 doesn't accept query strings with html files...

    Can anyone help?

    Thanks

    Monday, January 12, 2009 8:57 AM

Answers

  • User-47214744 posted

    Could it be that you just need to add the fckeditor.html as a Default Document?

    I am not familiar with what fckeditor.html is, but if the request ended up to the folder then probably need the default document instead of the directory browsing.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, January 12, 2009 7:03 PM

All replies

  • User989702501 posted

    I'm not sure about the editor app, but the error msgs is saying 'directory browsing not allowed', is it enable at the folder or ?

    Monday, January 12, 2009 8:59 AM
  • User1915089424 posted

    Hi,

    thanks for the fast answer.

    Yes, it says that directory browsing is disabled, but if I enable it, I receive the list of files in it instead of the fckeditor.html page...

    Monday, January 12, 2009 9:14 AM
  • User989702501 posted

    Err. well, that's what the editor complains about.. again.. not sure what exactlly needed by the app. You might want to check with the vendor or developers of the app and see if it supports running on IIS7 and does it required any special config.

    Monday, January 12, 2009 9:16 AM
  • User-47214744 posted

    Could it be that you just need to add the fckeditor.html as a Default Document?

    I am not familiar with what fckeditor.html is, but if the request ended up to the folder then probably need the default document instead of the directory browsing.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, January 12, 2009 7:03 PM