locked
SQL Database Project drop-down is empty RRS feed

  • Question

  • After adding a SQL Database project to my LightSwitch project in VS2013 preview, the "SQL Database Project" setting in the LightSwitch project properties becomes enabled but the list to choose from is empty.
    Tuesday, August 20, 2013 4:27 AM

Answers

  • HI Guy Godin

    I just noticed that there is a similar feedback, database project is not available in SQL Database project dropdown of LightSwitch project properties, you could check whether it is the same issue,

    #Database Project Not Available in SQL Database Project Dropdown of LightSwitch Project Properties

    Best Regards


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    • Marked as answer by Guy Godin Monday, August 26, 2013 6:20 AM
    Monday, August 26, 2013 3:08 AM

All replies

  • Hi Guy Godin

    According to your description, I'd also like to suggest you to check whether that file is really existed, at the same time you can also check whether it connects to SQL database correctly,

    In addition, Beth massi's will be good guide to work with SQL Server LocalDB in LightSwitch Projects,

    For detailed infomation: Working with SQL Server LocalDB in LightSwitch Projects

    Regards


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Wednesday, August 21, 2013 3:13 AM
  • Check that the file exists? Yes the project and database script files exist on disk and I did hit save. I even cleaned/rebuilt the solution, rebooted my computer and the drop down is still empty.
    Saturday, August 24, 2013 2:40 AM
  • HI Guy Godin

    I just noticed that there is a similar feedback, database project is not available in SQL Database project dropdown of LightSwitch project properties, you could check whether it is the same issue,

    #Database Project Not Available in SQL Database Project Dropdown of LightSwitch Project Properties

    Best Regards


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    • Marked as answer by Guy Godin Monday, August 26, 2013 6:20 AM
    Monday, August 26, 2013 3:08 AM
  • Hi Guy

    I have the same problem in vs2013 rtm. Finally I fixed the problem by execute two command run on cmd.exe.

    1. stop the instance of localdb which named "Projects" that created by SQL Database Project.

    sqllocaldb p projects

    2. delete the instance

    sqllocaldb d projects



    • Edited by Tobyee Wednesday, October 30, 2013 6:19 AM
    Wednesday, October 30, 2013 6:18 AM
  • I had the same problem. Neither the link nor the "MCD fix" that's linked inside of it are applicable.

    If you're still having problems with this check the installed versions of SQL Server Local DB. 

    If you have both versions it's likely that LightSwitch is defaulting to the 2012 version and the SQL Database Project defaults to the 2014 version. To fix this you'll need to reset the default Data Connections option at the Visual Studio level.

    For me it was Tools>Options>Database Tools> Data Connections.

    Once I changed mine from v11.0 to ProjectsV12, the SQL Database Projects dropdown worked without a hitch.


    • Edited by Garth HPE Thursday, August 7, 2014 10:48 PM Found the fix!
    • Proposed as answer by Garth HPE Thursday, August 7, 2014 10:48 PM
    Thursday, August 7, 2014 10:09 PM
  • I have this same issue. I added a database project to run a post deployment script and the drop down under the lightswitch project is blank.

    Changed the Tools => Options => Database Tools => Data Connections settings to:
    (LocalDB)\ProjectsV12

    But that did not fix it.

    Tried a build and it's still blank.

    Exited out of Visual Studio and re-opened the project, still didn't work.

    Visual studio is Ultimate 2013 version 12.0.31101.00 Update 4

    Friday, June 12, 2015 7:21 PM