none
VSTO addin not getting enabled in 64 bit Office 2010 and 64 bit Win 7 machine RRS feed

  • Question

  • Hi,

    I have created an VSTO addin for excel. which work fine on 32 bit office and machine, 64 bit office and 64 bit system if i install for current user where i make registry entry in current user. where as in 64 bit office and 64 bit system if i install it for all user where make entry in local machine, it shows up initially. But once i disable the addin in com addin menu and then later i try to re eanble it. it does not work out.

    after checking in the registry i found out that excel in creating a entry in current user where the load behaviour is changed.

    but when i delete the entry from current user then it seems to be working fine.

    can you all help this issue.

    Tuesday, October 30, 2012 1:07 PM

All replies

  • this is as expected - if you install add-in for all users, it ends up under HKLM registry key. But single user can still disable it and as a result entry for that particular user (HKCU) will appear for addin to indicate it is disabled. What do you want to achieve?
    Tuesday, October 30, 2012 2:15 PM
  • As i mentioned earlier. after disabling it when i re-enable from com add-in menu. Add-in does not load in the excel although the load behavior shows as Loads at start-up.
    Wednesday, October 31, 2012 4:40 AM
  • show us screenshots of your addin entry under HKLM and HKCU after you disable and enable it for single user.
    Wednesday, October 31, 2012 11:23 AM