locked
Advanced Logging on a Web Farm (Shared Configuration) RRS feed

  • Question

  • User1580727775 posted
    I am trying to find out if it is possible to use Advanced Logging on a web farm that uses Shared Configuration. We are running Windows 2008 R2 and after the install I do not see the icon for it in the IIS Manager. I have successfully installed and configured it on our Dev web server, which does NOT use Shared Configuration. Can anyone confirm if this is the case, or am I doing something wrong. Thank you, Jim
    Friday, June 8, 2012 3:49 PM

All replies

  • User-76669496 posted

    This Advanced Logging installation guide doesn't specify Shared Config in the Known Issues section.

    http://learn.iis.net/page.aspx/1035/advanced-logging-readme/ 

    Did you disable Shared Config on the web nodes before the installation of Advanced logging and perhaps reboot the nodes?

    Friday, June 8, 2012 11:31 PM
  • User1580727775 posted
    Well, it does appear to run in a shared configuration setting, but I had to turn off the shared configuration to install it. After it was installed, I could re-enable the shared configuration and when I configured one web server, they were all configured, as expected.
    Tuesday, June 19, 2012 11:33 AM
  • User-1035381163 posted

    Before 8.5, you had to install the add-on as a separate MSI but now in 8.5, it is part of the product.  What I am wondering is, can additional header fields be added to the logging without worrying about if shared config is on or not.  My guess is no.

    The advanced logging MSI would not even install if it saw IIS shared config turned on.

    Saturday, February 21, 2015 12:16 PM