locked
WCF Service Application throwing error after deployment RRS feed

  • Question

  • Hi,

    I created and WCF Service Application and deployed as it is to get it as service reference in Silverlight project. But I am not able to browse it at IIS it self and while giving service reference in my Silverlight project it is saying that there are no services present.

    I have given URL for reference as http://xx.xx.xx.xx/myserivce/Service1.svc?wsdl.

    Can any help on what should I do here.

    Thanks

    Sreenath

    Monday, April 11, 2011 1:42 AM

Answers

All replies

  • Can you just show us your Service Contract and service host's Web.config file. It will provide more insight to others.

    Monday, April 11, 2011 4:40 AM
  •  

    This is the web.config file in WCF Service applicatoion....and still I am not able to browse the WCF service in IIS 6 itself...through inetmgr..

    <?

    xml version="1.0"

    ?>

    <

    configuration

    >

    <

    appSettings

    />

    <

    connectionStrings

    />

    <

    system.web

    >

    <

    compilation debug="true" targetFramework="4.0"

    />

    <!--

    The <authentication> section enables configuration

    of the security authentication mode used by

    ASP.NET to identify an incoming user.

    -->

    <

    authentication mode="Windows"

    />

    <!--

    The <customErrors> section enables configuration

    of what to do if/when an unhandled error occurs

    during the execution of a request. Specifically,

    it enables developers to configure html error pages

    to be displayed in place of a error stack trace.

    <customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm">

    <error statusCode="403" redirect="NoAccess.htm" />

    <error statusCode="404" redirect="FileNotFound.htm" />

    </customErrors>

    -->

    <

    pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID"

    />

    </

    system.web

    >

    <!--

    The system.webServer section is required for running ASP.NET AJAX under Internet

    Information Services 7.0. It is not necessary for previous version of IIS.

    -->

    <

    system.webServer

    >

    <

    modules runAllManagedModulesForAllRequests="true"

    />

    </

    system.webServer

    >

    <

    system.serviceModel

    >

    <

    services

    >

    <

    service name="IncWcfService.Service1" behaviorConfiguration="IncWcfService.Service1Behavior"

    >

    <!--

    Service Endpoints

    -->

    <

    endpoint name="SilverLightendpoint" address="" binding="basicHttpBinding" contract="IncWcfService.IService1"

    />

    <

    endpoint name="MetaDataSilverlightEndpoint" address="mex" binding="mexHttpBinding" contract="IMetadataExchange"

    />

    </

    service

    >

    </

    services

    >

    <

    serviceHostingEnvironment multipleSiteBindingsEnabled="True"

    />

    <

    behaviors

    >

    <

    serviceBehaviors

    >

    <

    behavior name="IncWcfService.Service1Behavior"

    >

    <

    serviceMetadata httpGetEnabled="true"

    />

    <

    serviceDebug includeExceptionDetailInFaults="false"

    />

    </

    behavior

    >

    </

    serviceBehaviors

    >

    </

    behaviors

    >

    </

    system.serviceModel

    >

    </

    configuration

    >

     

    Monday, April 11, 2011 4:49 AM
  • And i have used clientaccesspolicy.xml

    <?

     

    xml version="1.0" encoding="utf-8"

    ?>

    <

     

    access-policy

    >

    <

     

    cross-domain-access

    >

    <

     

    policy

    >

    <

     

    allow-from http-request-headers="SOAPAction,Content-Type"

    >

    <

     

    domain uri="*"

    />

    </

     

    allow-from

    >

    <

     

    grant-to

    >

    <

     

    resource path="/" include-subpaths="true"

    />

    </

     

    grant-to

    >

    </

     

    policy

    >

    </

     

    cross-domain-access

    >

    </

     

    access-policy

    >

    Monday, April 11, 2011 5:02 AM
  • Hi,

    I Enabled anonymous auth mode and now I am able to browse the Service in IIS 6. But when I took this as a reference in my silverlight application it is giving error as "The remote server returned an error: NotFound", what I do for this. I have my crossdomain.xml and clientaccesspolicy.xml files is @ c:\inetpub\wwwroot folder.

    Any suggestions please.

    Monday, April 11, 2011 6:31 AM
  • You may get better help in the correct forum: http://forums.silverlight.net/forums/46.aspx

    Monday, April 11, 2011 1:36 PM