none
.net Framework 2.0 fault installation RRS feed

  • Question

  • Hi there,

    i have a form application that uses an access database. It works fine (used from many different users with Windoxs xp, Vista, 7). Resently 2 users have mentioned the same error (both windows xp sp3). The error was that the application when it was trying to read the database it returned 0 rows. I managed to debug the application at one of these machines and figured out that  the error was the following:

    "Impossible to load the file or the assembly 'System.EnterpriseServices.Wrapper.dll' or one of his dependence. Impossible to find the specific file."

    I have questioned the forum for this error and i got the answer that .net framework 2.0 is faulty installed and must be repaired. i reinstalled the framework to that machine and the problem solved.

    My question is if there is a simply way to fix the framework without uninstalling and installing it again. Most of the users are inexperienced and it is very difficult to explain to then the procedure. I have tried the Microsoft "fixit" but it didn't solve the problem.

    thanks in advance.

     

    Friday, August 5, 2011 10:58 AM

Answers

  • Have you tried right-clicking on the .NET Framework entry in the installed programs list, then selecting repair from the context menu (you may have to select uninstall/change from the menu, then select repair from the dialog)?

     

    Friday, August 5, 2011 12:56 PM