locked
After Updating debug error Application.Server.dll RRS feed

  • Question

  • Hello Guys,

    I have updated several extensions that produced an error only when i run my application in debug mode!  I have tried almost everything.  here is the error

    Error 1 Could not copy the file "obj\Debug\Application.Server.dll" because it was not found. AVISCDS_OPS.Server
    Error 2 Could not copy the file "C:\Users\Ali\Documents\Visual Studio 2013\Projects\AVISCDS_OPS\AVISCDS_OPS\AVISCDS_OPS.Server\obj\Debug\Application.Server.dll" because it was not found. C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\LightSwitch\v4.0\Microsoft.LightSwitch.targets 103 10 AVISCDS_OPS


    ----------------------------

    Friday, January 30, 2015 9:15 PM

Answers

  • Found a solution!  it appears that the server was not being built properly.  When I try to add a new field in a table it generated an error.  After which I tried to add a new table and the server rebuilt.  everything is fine now!

    thanks


    ----------------------------

    • Marked as answer by AliFarahat Wednesday, February 4, 2015 6:40 PM
    Wednesday, February 4, 2015 6:40 PM

All replies

  • HI AliFarahat,

    If you have LightSwitch Extension Projects in your project, here is the guide to upgrade LightSwitch Extension Projects to Visual Studio 2013. Please check whether it helps you.

    If you have any issue, please let me know.

    Best regards,

    Angie


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, February 2, 2015 8:14 AM
  • Hey Angie,

    Thank you for your reply.  I think I wasn't clear about the problem I am facing.  so see below error code generated.  The solution build fine when its set to release its only the debug that's generating the error.  I believe that this happened when I updated the extensions related to the project.

    Error 2 Could not copy the file "C:\Users\Ali\Documents\Visual Studio 2013\Projects\AVISCDS_OPS\AVISCDS_OPS\AVISCDS_OPS.Server\obj\Debug\Application.Server.dll" because it was not found. C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\LightSwitch\v4.0\Microsoft.LightSwitch.targets 103 10 AVISCDS_OPS


    ----------------------------

    When I double click on the error I get the text below in a file called Microsoft.lightswitch.targets

            <

    CopySourceFiles="%(_ProjectOutputFile.Identity)"


                 

    DestinationFolder="$(OutDir)%(SubFolder)"


                 

    SkipUnchangedFiles="true"


                 

    Condition="'@(_ProjectOutputFile)' != '' and '%(_ProjectOutputFile.CopyLocal)' == 'true' ">

                <

    OutputTaskParameter="DestinationFiles"ItemName="FileWrites"/>

            </

    Copy>


    • Edited by AliFarahat Wednesday, February 4, 2015 8:26 AM
    Wednesday, February 4, 2015 8:23 AM
  • Found a solution!  it appears that the server was not being built properly.  When I try to add a new field in a table it generated an error.  After which I tried to add a new table and the server rebuilt.  everything is fine now!

    thanks


    ----------------------------

    • Marked as answer by AliFarahat Wednesday, February 4, 2015 6:40 PM
    Wednesday, February 4, 2015 6:40 PM