locked
wcf ria problem RRS feed

  • Question

  • Hello i´m trying to create a ria service following this tutorial:

    http://lightswitchhelpwebsite.com/Forum/tabid/63/aft/89/Default.aspx

    i have done everything step by step over 30 times and i cant create a ria service

    http://oi45.tinypic.com/2817kfo.jpg


    please help

    Thursday, February 14, 2013 8:55 PM

Answers

  • I remember this issue. Have you included all the references in your code?

    if you follow this article *Combining two tables in LightSwitch you will see what I mean

    From about here onwards

    HTH

    *title for Yann's benefit as he keeps editing my this links :) Always appreciated Yann


    If you found this post helpful, please mark it as helpful. If by some chance I answered the question, please mark the question as answered. That way you will help more people like me :)

    • Marked as answer by Angie Xu Tuesday, February 26, 2013 5:29 AM
    Thursday, February 14, 2013 9:18 PM

All replies

  • I remember this issue. Have you included all the references in your code?

    if you follow this article *Combining two tables in LightSwitch you will see what I mean

    From about here onwards

    HTH

    *title for Yann's benefit as he keeps editing my this links :) Always appreciated Yann


    If you found this post helpful, please mark it as helpful. If by some chance I answered the question, please mark the question as answered. That way you will help more people like me :)

    • Marked as answer by Angie Xu Tuesday, February 26, 2013 5:29 AM
    Thursday, February 14, 2013 9:18 PM
  • Another point to remember is that your WCF service must target .net framework 4.0 and not 4.5

    Example of person who had issue also


    If you found this post helpful, please mark it as helpful. If by some chance I answered the question, please mark the question as answered. That way you will help more people like me :)

    Thursday, February 14, 2013 9:33 PM
  • I remember this issue. Have you included all the references in your code?

    if you follow this article *Combining two tables in LightSwitch you will see what I mean

    From about here onwards

    HTH

    *title for Yann's benefit as he keeps editing my this links :) Always appreciated Yann


    If you found this post helpful, please mark it as helpful. If by some chance I answered the question, please mark the question as answered. That way you will help more people like me :)

    how can i i add this reference:

    using ApplicationData.Implementation;

    Friday, February 15, 2013 2:20 AM
  • did you follow the steps in the post?

    It is at this point that ittells you to add as a link to the ApplicationData.cs file within the ServerGenerated\GeneratedArtifacts folder.

    Also, if you read the comments in the post you will notice that some people have just commented this line out and still had results.....how I dont know but that should help


    If you found this post helpful, please mark it as helpful. If by some chance I answered the question, please mark the question as answered. That way you will help more people like me :)

    Friday, February 15, 2013 6:27 AM