locked
Debugging problem in VS 2010 / Silverlight 4 RRS feed

  • Question

  • Hello,

    I've just installed VS 2010 (alongside VS 2008) on a WinXP SP3 machine and installed Silverlight 4 but I'm having difficulty getting debugging breakpoints to work properly.

    I’m just now getting started installing the software I think I need for Silverlight development.  I’ve installed VS 2010 (a full version) with no apparent problems.  I also installed the “Silverlight4_Tools.exe” found at http://www.microsoft.com/downloads/details.aspx?FamilyID=40ef0f31-cb95-426d-9ce0-00dcfabf3df5&displaylang=en

    I then created a simple Silverlight application in VS 2010 using the sample found at: http://msdn.microsoft.com/en-us/library/cc838218%28v=VS.95%29.aspx.

    However, I can’t seem to get debugging to work.  My code runs and my changes show up in a browser (Firefox) when I click debug or F5, but breakpoints I’ve set in the code-behind click event handler are never reached.  I don't get any error messages regarding debugging (or anything else).

    Some internet forum postings found through Google searching suggested that I need to re-install the Silverlight 4 developer runtime, “Silverlight_Developer.exe”, found at: http://go.microsoft.com/fwlink/?LinkID=188039.  I did that also, but don’t seem to see any difference in my debugging experience.

    Can you offer any suggestions or links for me to explore?

    Some background...  Before I installed VS 2010, I had previously installed the Silverlight 3 SDK and the Silverlight 3 plugin.  After I installed VS 2010, I uninstalled all Silverlight related entries in Add/Remove Programs and then installed the Silverlight 4 Tools and Silverlight 4 Developer runtime.  Is my installation somehow corrupted?  Any suggestions for uninstalling and reinstalling VS 2010 / Silverlight including order of operations?  VS 2008 can't be uninstalled at this time.

    Thanks for your help

    Wednesday, August 18, 2010 12:45 PM

Answers

All replies