none
.NET 4 Corruption on Win 7 x64 RRS feed

  • General discussion

  • Had windows updates to .net repeatedly fail recently so I tried to do a repair install but kept coming up against some 'trust error'. Anyway long story short I've tried to get around the issue by eiter unistalling my existing installation or installing standalone copy from the MS website over my old one. Unfortunately that hasn't worked either as the process fails as well. My log file is as follows:

    When attempting to install via the built-in admin account:

    [CODE]

    OS Version = 6.1.7601, Platform 2, Service Pack 1
    OS Description = Windows 7 - x64 Ultimate Edition Service Pack 1
    CommandLine = F:\ea173bfaed5d5ad19b1cce\\Setup.exe /x86 /x64
    TimeZone = AUS Eastern Daylight Time
    Initial LCID = 3081
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: Disabled
    Number of applicable items: 11
    Exe (F:\ea173bfaed5d5ad19b1cce\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (F:\ea173bfaed5d5ad19b1cce\Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null).
    Exe (F:\ea173bfaed5d5ad19b1cce\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    MSI (F:\ea173bfaed5d5ad19b1cce\netfx_Extended_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20120219_210113592-MSI_netfx_Extended_x64.msi.txt
    Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:00:36).

    [/CODE]

    I have re-installed KB958488 just in case to no avail.

    Any ideas?


    • Edited by DCCXVIII Sunday, February 19, 2012 10:21 AM
    Sunday, February 19, 2012 10:12 AM

All replies

  • Hi DCCXVIII,

    Welcome to the MSDN forum.

    The error code 0x240006 occurred in your log means “The update to be installed is already installed on the system”, so it is not the problem which lead the failed installation. To find the root cause, I recommend you collect the logs via this tool: http://www.microsoft.com/downloads/details.aspx?FamilyID=e0da314f-6216-4a18-bc6b-7d29cf83af20&displaylang=en

    Upload the vslogs.cabfile located in %temp% folder to an open website like Windows Live SkyDrive or send it to me (E-mail:v-alsun_at_microsoft_dot_com).

    Note: Please attach the link of this post in the mail.

    Also, you can try these common steps:

    1. Download a fresh copy of the standalone installer for
    .NET Framework 4.0:
    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

    2. Before running the installer, apply irarab's fix as follows:

    "I went to "C:\Windows\Microsoft.NET" there is a directory called "assembly".

    I looked in the directory and found some subdirectories with lots of old dot net 4 files. I renamed the directory assembly2 and tried to install Dot Net 4 and it worked!!!!

    (You can't delete the assembly directory unless you take ownership of it but you can rename it.)"

    Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 as Administrator.

    If you have any other problem, please feel free to let me know.

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us

    Monday, February 20, 2012 5:43 AM