none
error when windows iis image pushing to Linux Repository RRS feed

  • Question

  • Dears,

    Any help on the below issue will be highly appreciated.

    I am facing issue when I am trying to push windows iis image pushing to Linux Repository.

    ### Actual behavior
    C:\Windows\system32>docker images
    REPOSITORY                    TAG                 IMAGE ID            CREATED             SIZE
    webdeploy                     latest              00e5ab98ca2a        14 hours ago        7.982 GB
    nginx                         latest              f616c9331369        14 hours ago        7.889 GB
    192.168.137.101:7777/iis      latest              03827c9ad22c        14 hours ago        7.901 GB
    iis                           latest              03827c9ad22c        14 hours ago        7.901 GB
    ane-commit-iis                latest              3d77350d6c70        15 hours ago        7.902 GB
    microsoft/iis                 latest              accd044753c1        3 weeks ago         7.907 GB
    microsoft/windowsservercore   10.0.14300.1030     02cb7f65d61b        10 weeks ago        7.764 GB
    microsoft/windowsservercore   latest              02cb7f65d61b        10 weeks ago        7.764 GB
    C:\Windows\system32>
    C:\Windows\system32>docker push 192.168.137.101:7777/iis
    The push refers to a repository [192.168.137.101:7777/iis]
    Get https://192.168.137.101:7777/v1/_ping: http: server gave HTTP response to HTTPS client

    ### Information

    PS C:\Windows\system32> docker version
    Client:
     Version:      1.12.1
     API version:  1.24
     Go version:   go1.6.3
     Git commit:   23cf638
     Built:        Thu Aug 18 17:52:38 2016
     OS/Arch:      windows/amd64

    Server:
     Version:      1.12.1
     API version:  1.24
     Go version:   go1.6.3
     Git commit:   23cf638
     Built:        Thu Aug 18 17:52:38 2016
     OS/Arch:      windows/amd64
    PS C:\Windows\system32>


    Docker Linux Repository docker host version information
    --------------
    Client:
     Version:      1.12.1
     API version:  1.24
     Go version:   go1.6.3
     Git commit:   23cf638
     Built:
     OS/Arch:      linux/amd64

    Server:
     Version:      1.12.1
     API version:  1.24
     Go version:   go1.6.3
     Git commit:   23cf638
     Built:
     OS/Arch:      linux/amd64

    ### Steps to reproduce the behavior

    docker tag iis 192.168.137.101:7777/iis
    docker push 192.168.137.101:7777/iis

    Sincere Regards,

    Aneesh

    Saturday, August 27, 2016 9:30 AM

All replies

  • Google can really help you here, not sure about Bing. :)

    http://stackoverflow.com/questions/38695515/can-not-pull-push-images-after-update-docker-to-1-12

    https://github.com/docker/distribution/issues/1874

    Basically:

    " The --insecure-registry=myip:5000 flag is not getting set on the daemon, causing this error."

    Wednesday, August 31, 2016 10:29 AM