none
Transcend TS-PDU3 USB3.0 Expansion Card with multiple samples RRS feed

  • Question

  • Hello,

    I bought the Transcend TS-PDU3 USB3.0 Expansion Card because I read that it was supported. First of all, the verifier says "No supported USB 3.0 ports detected", even though actually the Kinect is recognized and all the samples work. The verifier also complains about insufficient framerate (the card is mounted on a PCI x1 slot because I don't have another slot), but if I run some samples (for instance I tried launching RGB, depth, body index and body simultaneously), it looks like the insufficient framerate problem on the verifier disappears and everything works like a charm. This is the first very weird behavior. Then, I tried to launch a simple code that I have written, where I try to record RGB, depth, body and body index simultaneously (copied and pasted the single c++ samples in a bigger one). If I record only one stream, it works perfectly. If I start recording for instance RGB and body index, then the program gets stuck, which is weird since I am able to launch the samples from the kinect browser simultaneously. Also, the Kinect Studio does not work at all. It says that it cannot connect to the Kinect Studio Host Service. Any idea about this really weird behavior?

    Thanks

    Friday, October 3, 2014 9:31 PM

All replies

  • PCi x1 slot is not always PCIx Gen 2.0 enabled(capable of 5.0GB/s). Try other slots to confirm you are getting the behavior with other slots including your PCI x16 slot. As a test, move the graphics card to another slot to test.

    Carmine Sirignano - MSFT

    Monday, October 6, 2014 6:35 PM
  • Hi Carmine,

    thank you for your answer. Unfortunately I don't have any other slot to put the graphics card on. I ended up using a Surface Pro 3.

    Thanks

    Friday, October 17, 2014 2:31 AM
  • Hi, I have similar problems with the Windows 10 upgrade and a TS-PDU3 (Transcend's 2x USB 3.0 ports card)!

    It worked just fine with Windows 7 and Transcend's driver from their web site. But as soon I received the Windows 10 update, in the Device Manager now there is a Microsoft driver v0.96 which seems to be unreplaceble by the Transcend driver - it says that a newer driver is already there.

    Under Windows 10 / 32 after the upgrade it started to be as slow as a USB 2.0 connector (3 - 4 Mb copy speed) and after a while the driver diconnected the hard disk saying that it received error messages from the card and therefore turned it off.

    Under Windows 10 / 64 most times the TS-PDU3 doesn't work at all or f it works, it disconnects rather sooner than later and shows the yellow tringle over the driver icon in the Device Manager.

    Wednesday, September 2, 2015 11:42 AM