locked
Can not download large files ASP +IIS 7.5 RRS feed

  • Question

  • User-332009586 posted

    Hello everybody 

    I have my project about download file from web server .

    I'm try download file type is .txt  is success.

    but if i'm try download file type is .exe  Size = 856 KB  is not success.

    Help me please.

    Thank you.........

    Monday, June 23, 2014 11:50 PM

All replies

  • User1183424175 posted

    Hi,

    856KB, I think, it is not large files. It maybe file mime types issue. PLease make sure

    • MIME Type definitely exists for the .EXE extension.
    • configure Execute Permission to "None"

    For more information, you can refer to the blog:

    http://blogs.msdn.com/b/david.wang/archive/2005/10/17/howto-allow-file-downloads-including-exe-on-iis-6-part-2.aspx

    #How to configure IIS 7 to allow downloading .exe files

    http://mike-ward.net/blog/post/00631/how-to-configure-iis-7-to-allow-downloading-exe-files

    Hope it can help you.

    Tuesday, June 24, 2014 10:34 PM
  • User-332009586 posted

    hi 

    i'm  configure IIS 7 to allow downloading .exe files  -->> 

    Handler Mappings -> Add Module Mapping

       Request path: *.exe

       Module : CgiModule

       Name : Test

    Request Restrictions..

       Mapping : File

       Verbs : All verbs

       Access : None

    but can not download exe file 

    Wednesday, June 25, 2014 3:00 AM
  • User-332009586 posted

    I'm try download exe file size < 2 KB It can download success

    but if I'm try download file size > 2 KB It can not downdload file to success

    Thursday, June 26, 2014 2:39 AM
  • User1183424175 posted

    Hi,

    2kb? But I think you can try setting the "Maximum allows content length" value in IIS Manager -> Features -> Request Filtering -> Edit Feature settings.

    For more information, you can refer here

    http://www.web-site-scripts.com/knowledge-base/article/AA-00696/0/Increasing-maximum-allowed-size-for-uploads-on-IIS7.html

    Monday, June 30, 2014 5:10 AM
  • User-332009586 posted

    I'm trying set "Maximum allows content length" but not work

    Monday, June 30, 2014 9:56 PM
  • User1183424175 posted

    Hi,

    I think you can try removing your handler mapping for .exe file. Just add mime types for it. 

    • Now once you’ve single clicked on your websites root folder in the nodes, select “MIME Types” from the icons in the middle stage.
    • Now click the “Add…” button on your right hand side and add the text exactly as below.
    • You’re done! Go head to that http:// address that you have and now the file will download from the IIS 7 web server correctly!

    For more information, you can also refer here

    http://blogs.vmware.com/thinapp/2008/10/how-to-configur.html

    Tuesday, July 1, 2014 7:51 AM
  • User-332009586 posted

    It not work if I'm write code load file  which size of file < 2 kb I can download file to success

    but if i'm write code load file  which size of file > 2 kb I can not download file to success 

    and i'm try specify Maximum Requesting Entity Body Limit = 214748364 on IIS Manager.

    but not work

    Thank you.....

    Wednesday, July 2, 2014 10:40 PM