locked
Server-side migration failing with "[ASEOLEDB]Could not load code page for requested charset" RRS feed

  • Question

  • I'm using SSMA v4.2 to migrate from an ASE 12.5.4 server to a SS2008.  I've successfully migrated the schema and most of the data using client-side migration.  I'm now trying to migrate data using server-side migration for the same tables I've successfully migrated using client-side migration.

    Here's the log info from the migration attempt:

    Migrating data...
    Analyzing metadata...
    Preparing table mydb.dbo.mytable...
    Preparing data migration package...
    Starting data migration Engine
    Starting data migration...
     [00000]
    [Native Code: 30061]
    [ASEOLEDB]Could not load code page for requested charset
    [1ZZ001]
    [Native Code: 30016]
    [ASEOLEDB]Internal Error
    Data migration operation has finished.
     0 table(s) successfully migrated.
     0 table(s) partially migrated.
     1 table(s) failed to migrate.

    I have the ASE client installed on the SS2008 server and I verified that the client contains the character set that is being used on the ASE server.  It seems like I need to be able to tell the ASE client which character set I want to connect with but am not sure how that's accomplished.  Do I configure an OLE DB data source for ASE on the SS2008 server?  Do I use the "advanced mode" on SSMA's ASE login dialog to specify a connection string and specify the charset within that?

    TIA,

    Stuart

    Monday, February 14, 2011 10:22 PM

All replies

  • Could this be a 32-bit/64-bit issue (even though it appears that the connection is being made - it just can't successfully negotiate the code page)? The ASE server is 32-bit and the SS2008 server is 64-bit.
    Wednesday, February 16, 2011 6:33 PM
  • Try specifying the connection string in advance mode by setting the CHARSET property.

    User ID=uid;PWD=pwd; CHARSET=cp850; PROVIDER=ASEOLEDB.1; SERVER=mymachine; PORT=5000;

     

     

    Wednesday, February 16, 2011 7:23 PM
  • I've tried specifying the charset in the connection string (as well as the clientcharset) but that didn't seem to make any difference.  I don't understand why it wouldn't just take the character set specified by the server...

    Will the SQL Server Agent use the native client or will it only use OLEDB or ADO.NET?

    As a test, I placed another app on MS server that connects to the ASE server using the native client but didn't experience any issues.

     

    Wednesday, February 16, 2011 9:23 PM
  • I'm trying to use the ADO.NET driver instead of OLEDB to see if that makes any difference.  What value do I specify for Provider in the connect string for an ado.net connection? 
    Wednesday, February 16, 2011 11:18 PM
  • I'm trying to use the ADO.NET driver instead of OLEDB to see if that makes any difference.  What value do I specify for Provider in the connect string for an ado.net connection? 


    If you are using ADO.NET driver, you could using one as below:

    Data Source=myServerAddress;Initial Catalog=myDataBase;Integrated Security=SSPI;
    

    By the way, you should be able to find all connection string required at http://www.connectionstrings.com/sql-server-2008.

    Hope this helps.


    Best Regards,
    Chunsong Feng

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, February 22, 2011 11:44 AM
  • Try use ODBC, create a system/user DSN to use ODBC?

     

    simply googled a page which seems same problem

    http://social.msdn.microsoft.com/Forums/en-US/sqlintegrationservices/thread/2e0605a0-1dd6-4280-a96f-4d25fd600a82


    If you think my suggestion is useful, please rate it as helpful.
    If it has helped you to resolve the problem, please Mark it as Answer.

    Sevengiants.com
    Tuesday, February 22, 2011 12:33 PM