none
.NET 4.0 Extension Assembly for Small Basic? RRS feed

  • Question

  • Is there any way to create a Small Basic extension assembly with .NET 4.0?  It look like only .NET 3.5 assemblies in the lib directory are found by Small Basic.  I want to reference an assembly that is written in .NET 4.0.

    Thanks,

    Michael


    Michael S. Scherotter Media Experience Evangelist Microsoft Corporation http://blogs.msdn.com/synergist http://twitter.com/synergist http://facebook.com/synergist
    Sunday, June 26, 2011 4:14 PM

Answers

  • Small Basic uses .Net 3.5 so .Net 4.0 assemblies won't work. You just have to wait until Small Basic becomes .Net 4.0 program.
    Sorry My Bad English
    Monday, June 27, 2011 7:43 AM

All replies

  • Hi,

    Not as far as I know.  Any dll has to be targeted to .Net3.5.  There are some posts and question on similar topics elsewhere and it may be possible to fool it but it certainly doesn't seem to be a generally supported option.  You may want to try posting on some .Net specific forums (if you get a definitive answer then post back here).  I guess at some point if the SmallBasic project is maintained by MS it will move to .Net 4.

    Sunday, June 26, 2011 4:46 PM
    Moderator
  • Small Basic uses .Net 3.5 so .Net 4.0 assemblies won't work. You just have to wait until Small Basic becomes .Net 4.0 program.
    Sorry My Bad English
    Monday, June 27, 2011 7:43 AM