none
D2D samples work but WPF samples have very poor frame rate RRS feed

  • Question

  • Computer configuration:

    Dell m4800 (i7 2.7 Ghz; Nvidia K1100M)

    Windows 8.1 64-bit

    I have the latest Nvidia driver for the chipset installed (driver release date July 10, 2014).

    The D2D samples are working great - good frame rate in all cases (RGB color, infrared, depth, etc). The WPF samples show a frame rate of 1 fps - if that. What is the issue?

    I'm very new to D2D but is it possible to write D2D applications with C#?

    Wednesday, August 6, 2014 12:37 PM

All replies

  • Can you provide a DXDiag of the system? if you have a share that you can link to if you can't upload the file

    Carmine Sirignano - MSFT

    Tuesday, August 12, 2014 10:18 PM
  • Can you request to be added to the developer preview of the program. We would like you to test with the latest weekly builds.

    contact: k4w@microsoft.com with the title: Request for DPP access

    In there reference this thread so that we can fast track the request.


    Carmine Sirignano - MSFT

    Wednesday, August 13, 2014 5:47 PM
  • I'm having the same trouble. I've posted a new question in this forum, if there's any way you can help would be really great.

    Many thanks

    Thursday, August 14, 2014 10:28 PM
  • I just installed preview 1408 and it has the same issue where WPF samples perform very very poorly (even the color basic sample has frame rate of may be 1 every 5 seconds).
    Thursday, August 21, 2014 9:34 PM
  • I have the same problem ...

    I apply to DPP following your guidelines above.

    I hope in your support.

    Thanks

    Friday, August 22, 2014 2:05 PM
  • The issue may be related to the system power state. Are you running a laptop or desktop? Can you run one of the D2D samples in parallel with the WPF sample?

    The issue boils down to 2 reasons:

    • PCix configuration of the USB3 chipset
    • Power State of the CPU

    Having the USB card plugged into certain PCIe slots does not work well when the CPU is in reduced power mode, so we lose data. On some configurations of motherboards, the USB3 chipset is physically connected to the PCix bus and may not be changed.
     
    For the Power States, when the CPU is running in a reduced power state (when the load is light) AND the USB card is plugged into a PCIe slot which doesn’t directly connect to the CPU then we can get into a very bad state. When in this state we see data corruption in the color stream and large frame drops in the Depth and IR based streams. You can verify this by running an application that will add load to the CPU (e.g our D2D apps, compiling, a “while(true){}” loop, etc) and run the WPF sample in parallel. The additional load from the app will kick the CPU up to full power, temporarily correcting the issue.

    The fix is to remove one of the two states causing it, either the specific PCIe bus or power throttling on the CPU.

    • PCIx, as suggested in the troubleshooting thread, trial and error will need to be employed
    • Power State can be done through the Power settings of Windows.

    Carmine Sirignano - MSFT

    Monday, August 25, 2014 7:23 PM
  • I have the same problem using the 1408 adn 1407 releases. The power settings are already set to 100%.

    The Kinect freezes most of the times if a user is recognised, a second user is recognised or a recongised user moves a lot/fast.

    With 1406, I have no problems et al.

    Best Regards,

    Thasmiel

    Wednesday, September 3, 2014 9:15 AM
  • Did you try to fix this as proposed above... finding the right slot to put your USB card into, etc...


    Rob Relyea [MSFT] http://twitter.com/rrelyea

    Wednesday, September 3, 2014 9:01 PM
  • yes, I've tried. also updated driver and tried different systems. But no changes in the freezing behaviour so far :/
    Thursday, September 4, 2014 7:22 AM
  • Hi Carmine,

    I have not any Process Power Management on my Desktop computer.

    So I use powercfg /query (high performance profile) and it is:

        GUID Alias: SUB_PROCESSOR
        Power Setting GUID: "guidnumber"  (Minimum processor state)
          GUID Alias: PROCTHROTTLEMIN
          Minimum Possible Setting: 0x00000000
          Maximum Possible Setting: 0x00000064
          Possible Settings increment: 0x00000001
          Possible Settings units: %
        Current AC Power Setting Index: 0x00000064
        Current DC Power Setting Index: 0x00000005

        Power Setting GUID: "guidnumber"  (System cooling policy)
          GUID Alias: SYSCOOLPOL
          Possible Setting Index: 000
          Possible Setting Friendly Name: Passive
          Possible Setting Index: 001
          Possible Setting Friendly Name: Active
        Current AC Power Setting Index: 0x00000001
        Current DC Power Setting Index: 0x00000001

        Power Setting GUID: "guidnumber"  (Maximum processor state)
          GUID Alias: PROCTHROTTLEMAX
          Minimum Possible Setting: 0x00000000
          Maximum Possible Setting: 0x00000064
          Possible Settings increment: 0x00000001
          Possible Settings units: %
        Current AC Power Setting Index: 0x00000064
        Current DC Power Setting Index: 0x00000064

    There is any value to change?

    However I confirm that it is a cpu state issue.

    I tested running another thread with >= 50% of CPU utitilization and WPF sample apps works fine.

    There is other option to fix the issue?

    Thanks


    • Edited by kaz2057 Wednesday, September 10, 2014 1:06 PM
    Wednesday, September 10, 2014 1:05 PM
  • Hi, I'm having the same issue. 

    I have tried 1407, 1408 and 1409 releases and it does not work. I'm trying to find 1406 to test but I cannot find it. 

    The skeleton detection seems to work ok but the infrared example does not show any image at all and the hand gestures are not being detected, which is the main feature I want. 

    I tried different USB ports and changed the power configuration. 

    Also change the power management settings as indicated in this thread but nothing. 

    Is there anything else I could try? Or some info that I can send to help to resolve the issue?


    • Edited by p3t3r16 Thursday, September 18, 2014 9:37 AM Missed word
    Thursday, September 18, 2014 9:37 AM
  • If there is no Infrared Images, you should update your graphic drivers. Maybe that fixes some other issues as well.

    Thursday, September 18, 2014 9:44 AM
  • I updated the driver which fixed the IR issue but not the frame rate for WPF samples.
    Thursday, September 18, 2014 2:37 PM
  • if you are getting 30fps on the D2D samples, then the runtime and SDK are working correctly. Can you run both the D2D and WPF samples side-by-side and change the behavior? If so, the issue is with your CPU throttling down the CPU. Try another system.


    Carmine Sirignano - MSFT

    Thursday, September 18, 2014 6:30 PM
  • I solved the issue by updating the nvidia driver to the latest available. 

    Now the hand gestures are detected correctly. 

    Friday, September 19, 2014 2:10 PM