Error 183 vb 2003 Compact framework RRS feed

  • Question

  • Hi

    I have been working on a project and once completed I went to deploy it.  I built the cabs, tried installing and the program would not work.  I then tried to deploy via studio as if I was debugging and got a message box with #183:.  Nothing came after the 183, so I tried to run the app on the device and this time I got a message box with nothing more than: Exception.

    I then started putting in message boxes and discovered than the program will error out only when it tried to load an image, all forms without images work fine, but those with images do not work

    The project is quite large and has been working fine until now.  The last few weeks have been spent testing and debugging with only minor changes.  It is written in VB and uses SqlCe along with several commercial packages. 

    There were no changes from the last time it ran fine until it was packaged.  I built another machine to test it on and got the same errors.  I have asked other people to try it on their machine and they get the errors.

    I even tried rebuilding the sln file, and still get the errors.  Does anyone know what is causing the #183:?  or any other info that would help?

    Thanks in advance


    Saturday, December 30, 2006 7:40 PM


  • Turned out to be the uninstalls did not cleanly uninstall the apps, 3 for sqlce, 1 for opennetcf and one for the app generated by studio.  Dont know which one is guilty.
    Wednesday, January 3, 2007 6:33 PM

All replies

  • We have no way of knowing what you’re printing in your message box #183, so more info is needed. See this, items 7, 9, 10 and 12.

    I would suspect you're forgetting to install SQL CE or "several commercial packages".

    Saturday, December 30, 2006 7:51 PM
  • I am not printing anything in the messagebox #183, studio is doing that all by itself.  Again I am getting error 183 with no information, when I run it on the device all I get is exception, Again I am not putting any info in these message boxes.

    I am not forgetting sqlce or several commercial packages, if you are really interested I will be more than happy to list then, that comment was provided for information only.  I can no longer run it thru the debugger, I cannot install it, I can no longer do anything and nothing has changed except creating the cab files.

    if any of the post is unclear please let me know, i used message boxes to find it was images causing the error, all message boxes are removed from the app.  I cannot afford a modal app, and message boxes are only used to debug, this is real time data that cannot afford to be delayed due to a message box

    Sunday, December 31, 2006 12:56 AM
  • So this message is produced by VS 2003 on desktop and not on device while your application is running, is that correct? If so, have you tried repairing VS? If that does not work, how about removing/reinstalling it? Does it work on another machine (e.g. your colleague's PC or your laptop)? Perhaps you've done some changes to your PC? Could it be a hardware failure of some kind? Can you create and debug new device project? Desktop project?

    Sunday, December 31, 2006 3:07 AM
  • 183 is on the desktop, the plain exception is on the device.  I built another drive, tried repairing the original drive.  Tried other machines, tried other devices.

    the only change to the project is i built the cab file

    i can create other projects, I tried to recreate this project, trust me I have tried everything.  I cannot convert to 2005 due to some third party libs.

    impossible to be any type of hardware or machine failure, it is something with the project itself, or a file within, again it cannot load any forms with an image on it.  it will partially work in the emulator (impossible to it to work entirely in the emulator) but forms with images will load.


    Sunday, December 31, 2006 9:10 PM
  • So it's not VS issue and you simply have corrupted project. I would suggest rolling back to working version from your backup/source control. Before that move broken copy to another place and compare project files to see what exactly broke it.

    Sunday, December 31, 2006 10:05 PM
  • Yes it is, i have tried rebuilding the sln and same thing.  I have tried going back, using a saved copy, rolling back in vss, nothing
    Monday, January 1, 2007 12:46 AM
  • Too bad there's pretty much nothing I can do as that makes no sense to me. Your VS is not broken (you can create, compile and debug new projects fine, right?), your project is not broken (at it's restored from VSS) but it does not work for some reason…

    Calling support sounds like a good idea to me as your time probably worth way more than $245 or whatever it costs. Somebody should be able to login remotely to your system and take a look at what's going on.

    Monday, January 1, 2007 2:50 AM
  • Turned out to be the uninstalls did not cleanly uninstall the apps, 3 for sqlce, 1 for opennetcf and one for the app generated by studio.  Dont know which one is guilty.
    Wednesday, January 3, 2007 6:33 PM
  • hello, i have the same problem, and my solution was warm boot (soft reset)...

    Wednesday, January 17, 2007 2:07 PM
  • You can install .NET CF 1.0 manually.
    Thursday, November 12, 2009 3:26 PM