locked
Version of scikit-learn that can be used RRS feed

  • Question

  • Hi,

    It looks as though the version of scikit-learn that's installed by default for calling in python modules is 0.15.1. Is there any way of calling a more recent version? (e.g. 0.7)

    Thanks, James.

    Wednesday, March 2, 2016 11:05 PM

Answers

  • Hey James!

    Sorry about that, and yes we are working on a feature that will allow a user to bring different versions of packages in a more predictable manner for R + Python.

    The usual workaround is to zip up the dependencies and manually import them from the zip location. Scikit-learn, however, is a bit more involved as it requires special treatment with our sandbox. I'm not sure if just uploading your own version will work (maybe a subset will be fine for you) but you're welcome to try.

    Regards,

    AK

    • Marked as answer by Hai Ning Saturday, March 5, 2016 3:44 AM
    Thursday, March 3, 2016 6:58 PM

All replies

  • Hey James!

    Sorry about that, and yes we are working on a feature that will allow a user to bring different versions of packages in a more predictable manner for R + Python.

    The usual workaround is to zip up the dependencies and manually import them from the zip location. Scikit-learn, however, is a bit more involved as it requires special treatment with our sandbox. I'm not sure if just uploading your own version will work (maybe a subset will be fine for you) but you're welcome to try.

    Regards,

    AK

    • Marked as answer by Hai Ning Saturday, March 5, 2016 3:44 AM
    Thursday, March 3, 2016 6:58 PM
  • HI AK,

    Thanks, yes, that would certainly help. Not having 0.7+ is a bit of a showstopper for what I had in mind...

    James

    • Marked as answer by Hai Ning Saturday, March 5, 2016 3:44 AM
    • Unmarked as answer by Hai Ning Saturday, March 5, 2016 3:44 AM
    Thursday, March 3, 2016 9:37 PM
  • Any progress with this? Scikit-Learn is now up to version 18.1  while AzureML uses 15.1. Its an issue because of incompatabilities when trying to deserialise a model built in 18.1 to run with 15.1
    • Edited by Sagitto Monday, December 5, 2016 5:24 PM
    Monday, December 5, 2016 5:24 PM