none
Clean Installation of .NET Frameworks RRS feed

  • Question

  • For several months, Auto Updates has been unable to install something and the only message I get has to do with .NET FRAMEWORKS 1.1 service pack1.  Here is the whole thing: Microsoft .NET Framework 1.1 Service Pack 1 Security Update for Windows 2000, Windows XP, Windows Vista, Windows Server 2008, Windows 7, and Windows Server 2008 R2 (KB953297)

    Note that according to the Add/Remove Program control panel item, my XP home system was already up to .NET Frameworks 3.5. I wanted to do a clean install but the only things that would uninstall were the most recent programs (3.5 and 3.0 sp1(I think)). Still showing as installed are:
    3.0, 2.0 sp2, 2.0 SDK-ENU, 1.1 Hotfix (KB928366), and 1.1.

    Now I get setup errors as I try to uninstall to older versions of .NET Frameworks.

    No prerelease versions have ever been installed as far as I know.

    Where do I go from here?

    Thanks
    Tim Miner

    Below is info about my system as of this moment:
    OS Name Microsoft Windows XP Home Edition
    Version 5.1.2600 Service Pack 3 Build 2600
    OS Manufacturer Microsoft Corporation
    System Name TIMSLAPTOP
    System Manufacturer Hewlett-Packard
    System Model Presario X1000 (DZ297U#ABA)
    System Type X86-based PC
    Processor x86 Family 6 Model 9 Stepping 5 GenuineIntel ~1395 Mhz
    BIOS Version/Date Hewlett-Packard 68BAL Ver. F.50, 8/16/2004
    SMBIOS Version 2.3
    Windows Directory C:\WINDOWS
    System Directory C:\WINDOWS\system32
    Boot Device \Device\HarddiskVolume1
    Locale United States
    Hardware Abstraction Layer Version = "5.1.2600.5512 (xpsp.080413-2111)"
    User Name TIMSLAPTOP\Tim Miner
    Time Zone Pacific Standard Time
    Total Physical Memory 2,048.00 MB
    Available Physical Memory 1.32 GB
    Total Virtual Memory 2.00 GB
    Available Virtual Memory 1.96 GB
    Page File Space 2.60 GB
    Page File C:\pagefile.sys
    Sunday, January 10, 2010 11:40 PM

Answers

  • Hello,

    The .NET Framework 3.5 is an add-on that requires the .NET Framework 2.0 SP1 and the .NET Framework 3.0 SP1 to be present as prerequisites.  If you have the .NET Framework 3.5 installed, you will not be allowed to uninstall the .NET Framework 3.0 SP1 or 2.0 SP1 until you first uninstall the .NET Framework 3.5.  You will also not be allowed to uninstall the .NET Framework 2.0 SP1 until you first uninstall the .NET Framework 3.5 and the .NET Framework 3.0 SP1.

    In addition, the .NET Framework versions 1.1, and 2.0 are completely separate from each other, and one version can be present on a computer regardless of whether the other versions are present. When versions 1.1 and 2.0 are on the same computer, each version has its own common language runtime, class libraries, compiler, and so forth. As a result you could here uninstall 1.1.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Send us any feedback you have about the help from MSFT at fbmsdn@microsoft.com.
    Tuesday, January 12, 2010 8:42 AM
    Moderator