locked
NET Framework 3.5 Won't Install on Server 2012 R2 RRS feed

  • Question

  • User-1611843628 posted

    I've been having trouble installing NET Framework 3.5 on a 2012 R2 server.

    I've browsed around for a few different solutions... updates 2966827 and 2966828 are not installed, WSUS isn't installed, Windows Updates are enabled, and I've tried using both Install Role and Features through Server Manager and DISM.

    With DISM, I get an error message saying the resource cannot be downloaded.

    In the GUI, I get "The source files could not be found." I've tried using both the SxS folder of the install disc and even tried just download the exe and pointing to that. I get the same error for both.

    Any suggestions?

    Wednesday, July 12, 2017 7:24 AM

All replies

  • User2119946224 posted

    Hi,

    I had same problem with server 2012 R2. 

    Follow below steps before install .net framework.

    Download updates from below link. There will be multiple updates available. Download all from that.

    https://www.microsoft.com/en-us/download/details.aspx?id=42334

    Note:

    Make sure you follow the instillation instruction available in this link. I just copy here to highlight some of the portions:

    1. These KB's must be installed in the following order: clearcompressionflag.exe, KB2919355, KB2932046, KB2959977, KB2937592, KB2938439, and KB2934018.
    2. KB2919442 is a prerequisite for Windows Server 2012 R2 Update and should be installed before attempting to install KB2919355

    Hope it will help you resolve your issue. If yes please mark as answer.

    Regards,

    Wednesday, July 12, 2017 9:37 AM