none
Service Instance Stuck in Active state for long duration in BizTalk 2010 PROD Environment RRS feed

  • Question

  • Hi All,

    In one of my BizTalk 2010 environment there are plenty of service instances (messaging) stuck in Active state for days. I don't see any messages associated with these instances. So wanted to know why are they still in active state? how can i find the reason why they are stuck in active state with out  doing anything.

    Regards,

    Uday. 

    Friday, January 20, 2017 6:12 PM

Answers

  • Hi Uday

    Are these Isolated Host (IIS) message instances on ReceiveLocation(s)? If yes, I have seen it on occasion as well, and there is not much you can do. Make sure that you are processing messages fine from this ReceiveHost currently.

    If these are SendHost Instances, you can restart the Host Instance(s) and see if that helps.


    Thanks Arindam

    Saturday, January 21, 2017 9:19 AM
    Moderator
  • Service instance in active state ?

    So is your Orchestration waiting for correlated message from another application . It might worth to check your Service instance in Orchestration debugger and verify the flow were it is halted to process the next step ..If you are using Ordered delivery send port then you might see message processed slowly based on the load .

     

    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply

    Tuesday, January 24, 2017 5:51 AM

All replies

  • Hi Uday

    Are these Isolated Host (IIS) message instances on ReceiveLocation(s)? If yes, I have seen it on occasion as well, and there is not much you can do. Make sure that you are processing messages fine from this ReceiveHost currently.

    If these are SendHost Instances, you can restart the Host Instance(s) and see if that helps.


    Thanks Arindam

    Saturday, January 21, 2017 9:19 AM
    Moderator
  • Service instance in active state ?

    So is your Orchestration waiting for correlated message from another application . It might worth to check your Service instance in Orchestration debugger and verify the flow were it is halted to process the next step ..If you are using Ordered delivery send port then you might see message processed slowly based on the load .

     

    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply

    Tuesday, January 24, 2017 5:51 AM