none
Getting errors when trying to debug template project RRS feed

  • Question

  • Hello,

    I am following this guide: https://docs.microsoft.com/en-us/windows-hardware/drivers/gettingstarted/writing-a-umdf-driver-based-on-a-template

    On step 7->8 i encounter this error: http://puu.sh/wvpGy/cade3694d5.png

    I've tried restarting both machines several times, but nothing seems to work.

    How do I debug this debugging error?

    Monday, July 3, 2017 8:15 AM

All replies

  • If the network is working fine then on the target machine, open an admin command prompt and run the "Services.msc" command to open the MMC administration console for services. Select any service, then type the "w" key to reach the first service whose description starts with "w". Finally check the status of the "WDK Remote Communication Service". If it is stopped then restart it. Communication timeouts between the dev machine and the target during deployment indicate that this service may have stopped for some reason.

    You could also open an admin command prompt on the target and run the "sc query WdkSvc" command to check if the service is running and then run the "sc start WdkSvc" command if the service is not running.

    M. M.

    Tuesday, July 4, 2017 12:31 AM
  • Thanks for your reply Miles.

    When trying to start the WDK Remote Communication Service i get the error:

    "Windows could not start the [service] service on Local Computer.

    Error 1067: The process terminated unexpectedly."

    Tuesday, July 4, 2017 9:46 AM
  • Try to reinstall the package named "WDK Test Target Setup x64-x64_en-us" for an x64 target or "WDK Test Target Setup x86-x86_en-us" for an x86 target.

    The packages are located in the remote directory of the Windows Kit directory on the dev machine. For a default setup the path is:

    C:\Program Files (x86)\Windows Kits\10\Remote


    Note: the system log may give more informations about why the service is crashing.
    • Edited by Miles90 Wednesday, July 5, 2017 2:49 AM Added a note.
    Wednesday, July 5, 2017 2:46 AM
  • I reinstalled it and got the same error. I wrote down what the terminal on the test machine tried to do while the dev machine got tired of waiting:

    Custom Reboot:
    Executing command line: "C:\DrinverTest\devcon.exe" -f install C:\DriverTest\Drivers\UMDF2Driver1.inf Root\UMDF2Driver1

    Where is the system log?

    Wednesday, July 5, 2017 8:33 AM
  • The wdk service is running if the device installation command is executed. You may need to debug the host for user mode drivers WUDFHost.exe.

    https://docs.microsoft.com/en-us/windows-hardware/drivers/wdf/enabling-a-debugger#using-windbg-to-attach-manually-user-mode-debugging

    https://docs.microsoft.com/en-us/windows-hardware/drivers/wdf/videos--debugging-umdf-drivers

    To open the system log, launch the event viewer MMC console. Just launch the file Eventvwr.msc in a command prompt.

    The deployment system copies your driver package to the C:\DriverTest\Drivers dir and then the devcon command is executed. You can do this manually to check if devcon is hanging.
    Thursday, July 6, 2017 2:44 AM
  • I got a same issue.

    My UMDF2.0 driver work ok on Win8.1,but not work in Win10(1607)。

    I use vs2017(15.4) remote deploy and debug,  source machine is Win7, Target machine is Win10(1607), when runto the step "C:\DrinverTest\devcon.exe" -f install , the "WDK remote communication service" shutdown, vs remote debugger lost connection.

    Wednesday, November 22, 2017 8:24 AM