locked
Classic ASP & ISS 10, Windows 10 RRS feed

All replies

  • User690216013 posted

    You need to modify the ASP settings to log errors, https://docs.microsoft.com/en-us/iis/configuration/system.webserver/asp/#attributes 

    Wednesday, June 12, 2019 9:10 PM
  • User-848649084 posted

    Hi,

    To see the detailed error message of classic asp code you need to do some setting in iis.

    • Select a site or server from the connection pane.
    • First, double click the ASP icon to open the ASP page. Expand the Debugging Properties node and set Send Errors To Browser to True.

    • Go back to the IIS properties as shown above and open the section for Error Pages.
    • Select the Edit Feature Settings from the Action Pane on the right.

    Try to access the site and you could see the detail error message.

    Regards,
    Jalpa

    Thursday, June 13, 2019 2:29 AM
  • User698719112 posted

    I did have most of the setting you have mentioned, i.e up to "Send Errors to Browser = True". But it didn't work.

    Reading your solution, the last step Edit Error Page: I don't have the option to Edit Error Page Settings as you showed. When I tried to open Error Page, all I see is the list of errors code 401, 403, ..., 502

    Thursday, June 13, 2019 12:08 PM
  • User698719112 posted

    Update:  

    1. 1.  Set Codepage to 1252 as lextm suggested.
    2. 2.  Reviewed my ISS settings and found out that I have all the settings Jalpa has mentioned.

    I was able run my app at localhost. However when there is an error, I receive the same error message as the beginning. 

    "An error occurred on the server when processing the URL. Please contact the system administrator.  If you are the system administrator please click here to find out more about this error."

    Thank you for your help!

    1.  
    Thursday, June 13, 2019 12:15 PM
  • User-848649084 posted

    Do you have option Error pages like below?

    Open this feature and in that page you can see Edit feature setting in action pane select that option.

    Friday, June 14, 2019 1:26 AM
  • User698719112 posted

    Yes I do have that option. I did select the 3rd option on error pages as you suggested. On error, I am still getting this:

    An error occurred on the server when processing the URL. Please contact the system administrator.

    If you are the system administrator please click here to find out more about this error.

    Monday, June 24, 2019 6:52 PM
  • User-848649084 posted

    Could you select your site and select asp feature and share snapshot of the setting?

    Tuesday, June 25, 2019 1:10 AM
  • User698719112 posted

    Sorry, this is my very first time trying to insert an image. I entered the path of the file for "source" but it doesn't seem to work.

    Tuesday, June 25, 2019 12:15 PM
  • User698719112 posted

    Erros page

    Tuesday, June 25, 2019 12:32 PM
  • User-848649084 posted

    Hi,

    You could use this site to share image.

    https://imgur.com/upload

    Wednesday, June 26, 2019 1:12 AM