none
BizTalk 2013 R2 Connection failure with SAP while using WCF-SAP adapter RRS feed

  • Question

  • Hi All,

    I am getting below error in our production environment 

    Message Validation Error. Microsoft.ServiceModel.Channels.Common.ConnectionException: Details: ErrorCode=RFC_OK. ErrorGroup=RFC_ERROR_COMMUNICATION. SapErrorMessage=SAP_CMINIT3 : rc=20 > Connect to SAP gateway failed Connect_PM GWHOST=*****.*****.com, GWSERV=****, SYSNR=94 LOCATION CPIC (TCP/IP) on local host with Unicode ERROR max no of 100 conversations exceeded TIME Mon May 16 15:36:26 2016 RELEASE 710 COMPONENT CPIC (TCP/IP) with Unicode VERSION 3 RC 466 MODULE r3cpic.c LINE 13993 COUNTER 1. AdapterErrorMessage=. ---> Microsoft.Adapters.SAP.RFCException: Details: ErrorCode=RFC_OK. ErrorGroup=RFC_ERROR_COMMUNICATION. SapErrorMessage=SAP_CMINIT3 : rc=20 > Connect to SAP gateway failed Connect_PM GWHOST=*****.*****.com, GWSERV=sapgw94, SYSNR=94 LOCATION CPIC (TCP/IP) on local host with Unicode ERROR max no of 100 conversations exceeded TIME Mon May 16 15:36:26 2016 RELEASE 710 COMPONENT CPIC (TCP/IP) with Unicode VERSION 3 RC 466 MODULE r3cpic.c LINE 13993 COUNTER 1. AdapterErrorMessage=. at Microsoft.Adapters.SAP.RfcClientConnection.Open() at Microsoft.Adapters.SAP.SAPConnection.OpenClassicRfcConnection() at Microsoft.Adapters.SAP.SAPConnection.Open(TimeSpan timeout) --- End of inner exception stack trace --- 


    When i search I have got below kb article which points to fix for BizTalk adapter pack 2010 and adapter pack 2.0 
    https://support.microsoft.com/en-gb/kb/2552332


    So the question is the issue still exists in BizTalk 2013 R2 . If so , is there any hotfix?

    Earlier we had similar issue in our BizTalk 2010 environment where we had suggestion of creating two environment variables

    CPIC_MAX_CONV is 300 and MaxConnectionPerSystem is 150. Can we do similar thing in BizTalk 2013 R2 environment as well ?

    Thanks in Advance.
    Regards,
    Uday Kiran
    Monday, May 16, 2016 6:09 PM

Answers

  • Hi Uday,

    Refer this for more help: Troubleshooting Operational Issues

    SAP does not enable more than 100 connections into the system. To increase the maximum number of connections, you must create an environment variable on the computer that has the SAP client libraries installed and set it to a numeric value. The value you specify for this environment variable is the maximum number of connections that can be made into the SAP system. Create the environment variable with the following details:

    • Variable name: CPIC_MAX_CONV
    • Variable value: any positive numeric value. For example, to enable 200 connections into the SAP system, specify the value as 200.

    Also refer: https://wiki.scn.sap.com/wiki/display/ABAPConn/ERROR++max+no+of+100+conversations+exceeded

    This is SAP limitation and not BizTalk, so these changes apply to any computer that has the SAP client libraries installed.


    Rachit Sikroria (Microsoft Azure MVP)


    Monday, May 16, 2016 6:22 PM
    Moderator

All replies

  • Hi Uday,

    Refer this for more help: Troubleshooting Operational Issues

    SAP does not enable more than 100 connections into the system. To increase the maximum number of connections, you must create an environment variable on the computer that has the SAP client libraries installed and set it to a numeric value. The value you specify for this environment variable is the maximum number of connections that can be made into the SAP system. Create the environment variable with the following details:

    • Variable name: CPIC_MAX_CONV
    • Variable value: any positive numeric value. For example, to enable 200 connections into the SAP system, specify the value as 200.

    Also refer: https://wiki.scn.sap.com/wiki/display/ABAPConn/ERROR++max+no+of+100+conversations+exceeded

    This is SAP limitation and not BizTalk, so these changes apply to any computer that has the SAP client libraries installed.


    Rachit Sikroria (Microsoft Azure MVP)


    Monday, May 16, 2016 6:22 PM
    Moderator
  • Hi

    You can still apply the CPIC_MAX_CONV environment variable, as it's a SAP side setting-

    https://wiki.scn.sap.com/wiki/display/ABAPConn/ERROR++max+no+of+100+conversations+exceeded

    If this doesn't help, maybe you can open a case with MS, to check if the kb https://support.microsoft.com/en-gb/kb/2552332 needs to be created for 2013 R2. Normally, any change in an earlier CU is available in a higher version of the product by default, though.


    Thanks Arindam


    Monday, May 16, 2016 6:28 PM
    Moderator
  • Hi Rachit,

    Thanks for you reply.

    Are you saying that the issue mentioned in kb 2552332 is fixed in BizTalk 2013 R2 ? and issue occurs when we try to get more than 100 connections to SAP at same time and can be taken care by creating environment variable CPIC_MAX_CONV? What about Environment variable MaxConnectionPerSystem  is it necessary or not?

    Regards,

    Uday.

     

    Monday, May 16, 2016 6:35 PM
  • What I am saying is this is SAP limitation and not BizTalk, so these changes apply to any computer that has the SAP client libraries installed.

    So apply the same changes which you have done in your Biztalk server 2010 environment also on BizTalk 2013 R2 environment. 

    Go ahead with the changes on you UAT or Pre-Prod environment, test it and then apply to your Production environment.

    Refer to the links i have shared above. 


    Rachit Sikroria (Microsoft Azure MVP)

    Monday, May 16, 2016 6:39 PM
    Moderator