locked
I cannot browse my site published in iis 7 from another computer RRS feed

  • Question

  • User493793698 posted

    It's no problem when browse it in my localhost. However, whenever I tried to browse it from another computer I couldn't find my server. 

    All my firewall is turned off.

    Thanks for help!

    Monday, February 23, 2009 4:26 AM

All replies

  • User989702501 posted

    a) can you browse via the server ip ?
    b) what do you see in IE? page cannot be displayed or ?
    c) can you telnet serverip 80 ? to check if the http port is working?
    d) anything else in between ? router/proxy?

    Monday, February 23, 2009 5:10 AM
  • User493793698 posted

     a) I can't browse via the server IP and server name as well

    b) FF says: Cannot find my address http:/servername/mysite

    c) My port is 80

    d) There is nothing between...

     

    Monday, February 23, 2009 10:20 PM
  • User989702501 posted

    a) double check firewall is not blocking
    b) can you ping the server IP? servername?

    Tuesday, February 24, 2009 8:16 AM
  • User493793698 posted

    a)I turned off my firewalls

    b) Yes, I can

    Tuesday, February 24, 2009 8:41 PM
  • User-1796730883 posted

    Hi,

    1. Do you set proxy in the "another computer"?

    2. Can the "another computer" access internet?

    3. How many network card does the server using?

    4. can you access the server shared folder? like \\ServerIPAddreww\SharedFolder

    Regards

     

    Thursday, February 26, 2009 4:07 AM
  • User493793698 posted

     1. I don't set proxy

    2. It always connects to internet.

    3. I use 1 network card

    4. I can access my shared folders in the server.

    Thursday, February 26, 2009 8:30 PM
  • User-1232435574 posted

    I have the same problem.

    Do I have to configure IIS to browse the server from another computer or it's configure by default?

    Friday, February 27, 2009 5:51 AM
  • User1073881637 posted

    Allow port 80 on the windows firewall.   To test remote connection

    telnet x.x.x.x 80  (x.x.x.x replace with IIS server address)

    Friday, February 27, 2009 10:13 PM
  • User-1196222631 posted

    Hi. I had the same problems, trying to connect to my web site from another pc.

    First of all: You should publish your web site from Visual Studio, making, for example: http://localhost/BAK/ as Target location. BAK - is folder of your site, so you should connect to your site, using http://192.168.x.x/BAK/Default.aspx (FOR Example)

    The  second thing:  I had the same problem, until I added a rule to my Windows Firewall, that allows connections on 80 port. After this step I was able to see my web site from another computer.

    I hope, that it would help you.

    Good luck.

    Sunday, March 1, 2009 5:54 AM
  • User493793698 posted

     Vista cannot recognize the command telnet x.x.x.x 80

    My problem haven't been solved yet.

    :(

    Monday, March 2, 2009 9:34 AM
  • User1073881637 posted

    The telnet client isn't installed by default on Vista.  You can copy the EXE from a XP machine (c:\windows\system32) is the path. 

    Monday, March 2, 2009 11:18 AM
  • User989702501 posted

    Or get the wfetch to test.
    http://support.microsoft.com/?id=284285

    Tuesday, March 3, 2009 2:57 AM
  • User794619501 posted

    Thanks.. My issue was resolved by following svarphana's instruction.

    Friday, October 9, 2009 2:47 PM
  • User-745597155 posted
    Set the ;Windows ;Firewall; to off in the published computer....
    Wednesday, January 13, 2010 5:12 AM