locked
Microsoft Visual Studio pipe is being closed error. RRS feed

  • Question

  • I use Windows 10. I want to install Visual Studio 2012 Ultimate, then comes error like:

    Setup Engine

    Pipe is being closed.

    Microsoft Visual Studio 2012 Pre-Clean Tool

    Pipe is being closed.

    Microsoft Visual Studio Preparation

    Pipe is being closed.

    Microsoft Visual C++ 2012 Extended Libraries

    Pipe is being closed.

    How to fix that errors? (Sorry for bad English)



    Monday, June 27, 2016 8:41 AM

Answers

All replies

  • ImDyingToFeelAgain,

     I found a previous thread that matches you r issue :https://social.msdn.microsoft.com/Forums/en-US/32dc0942-5549-46fc-8a48-4f4d257797cc/vs-2012-setup-crashes-setup-engine-the-pipe-is-being-closed?forum=vssetup

    Regards,

     Holly   - If this was helpful to you, please vote helpful and propose it as an answer

    Monday, June 27, 2016 2:41 PM
  • Dear ImDyingToFeelAgain,

    Welcome to the MSDN forum.

    According to the error message "Setup engine Pipe is being closed", Holly's solution looks like reasonable, please follow it and see if this issue will occur or not.

    Meanwhile, I found another similar issue here: https://blogs.msdn.microsoft.com/vsnetsetup/2013/08/02/installation-of-visual-studio-2012-update-3-fails-with-error-the-pipe-is-being-closed/

    The workaround:

    To resolve this, you first need to download the complete ISO file of the update 3 from this direct link http://go.microsoft.com/fwlink/?LinkId=301705

    Once you have this downloaded, and extracted/mounted/burnt you need to open an administrative CMD window and navigate to …\packages\WinACK\ and install these 2 patches:

    I. Windows App Certification Kit x64-x86_en-us.msp

    II. Windows App Certification Kit Native Components-x64_en-us.msp

    Having installed this, you can then run the setup for Visual Studio 2012 Update 3 using the same .iso file that you had downloaded.

    If the same issue still persists, I need your help to gather the VS installation log. Please use http://aka.ms/vscollect to gather the installation logs. After using it, you will find vslogs.zip from %temp% folder. Please upload the file to https://skydrive.live.com/ and share the link here.

    Best regards,

    Sara


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. <br/> <br/> Click <a href="http://support.microsoft.com/common/survey.aspx?showpage=1&scid=sw%3Ben%3B3559&theme=tech"> HERE</a> to participate the survey.

    Tuesday, June 28, 2016 2:41 AM
  • Hi there. This may be an OLD question, but I had this error happen today. Heres what I found.

    Tried to update a program. Program finshed install, and restarted with "VCRUNTIME140_1.dll was not found". 

    Found that I needed to re-install Visual C++ 2019 Redistributable and when I tried, I got "Pipe is being closed."

    Turned out, i had OBS (Open Broadcast Software) Open. When the other program tried to install, it did not finish because of OBS. Because OBS was open I could not install VC redistro. So I closed OBS, and tried to install VC Redis, and it worked! Hurray! Hope this helps any other who made the same mistake.

    Tuesday, December 31, 2019 7:18 AM