locked
Microsoft® SQL Server® 2008 Express with Advanced Services SP1 Download Available? RRS feed

  • Question

  • Is there a SP1 integrated version of "Microsoft® SQL Server® 2008 Express with Advanced Services"?  I can only seem to find the RTM version and not one that already includes SP1 slipstreamed.  I see a download for "Microsoft® SQL Server® 2008 Express Edition Service Pack 1" but need the one with Advanced Services.

    Thanks

    Scott
    Wednesday, May 6, 2009 6:52 PM

Answers

All replies

  • Hello,

    Please, could you have a look on this thread ?
    http://social.msdn.microsoft.com/Forums/en-US/sqlexpress/thread/4d54be43-d245-45be-9105-c737210cee20
    and especially to the excellent and clear ( as always ) post of Mike Wachal ( the SQL Server 2008 SP1 is a patch applying to all editions of SQL Server 2008 (Express/Workgroup/Standard/Entreprise).
    Thanks to the persons who have conceived an unique patch : it is so easy to use ( and only one download...)
    But you have to apply it to each instance SQL Server 2008

    Don't hesitate to post again for more help or explanations

    Have a nice day
    Mark Post as helpful if it provides any help.Otherwise,leave it as it is.
    Wednesday, May 6, 2009 8:10 PM
  • There is no SQL Server 2008 with Advanced Services as a separate download. To upgrade to SP1, you have the following choices:
    1)  Install RTM and then apply SQL Server 2008 SP1 from http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=66ab3dbb-bf3e-4f46-9559-ccc6a4f9dc19
    2)  Install RTM and then go to Microsoft Update for SP1
    3) Create a slipstream drop and perform a single installation: http://blogs.msdn.com/petersad/archive/2009/02/25/sql-server-2008-creating-a-merged-slisptream-drop.aspx. The steps are nearly the same the steps documented here.  For step #1, download the Express Advanced package and extract as following "SQLEXPRADV_x86_ENU.exe /x:c=SQLServer2008_FullSP1.

    Thanks,
    Peter Saddow

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Sunday, May 10, 2009 3:21 AM
  • Hi ,

    I tried to create a slipstream for SQL Server 2008 with Advanced Services  with SP1. I followed the step below, but I get an issue but only with SQL Express Advanced Services. For SQL server Standard or enterprise, it works fine.

    Step 1 : Download  : Microsoft® SQL Server® 2008 Express with Advanced Services

    Step 2 : Extract it as following "SQLEXPRADV_x86_ENU.exe /x:c\SQLEXPR_x86_ENU

    Step 3 : Download : Microsoft® SQL Server® 2008 Express Edition Service Pack 1  (I didn't use SP1 because he got a error message)

    Step 4 : Extract as following "SQLServer2008SP1-KB968369-x86-ENU.exe /x:c\SQLEXPR_x86_ENU\PCU

    Step 5 : Copy Setup.exe and Setup.rll in c:\SQLEXPR_x86_ENU\PCU\x86\ to c:\SQLEXPR_x86_ENU\x86\ to update the original

    Step 6 : Copy all files not the folders, except the Microsoft.SQL.Chainer.PackageData.dll, in c:\SQLEXPR_x86_ENU\PCU\ to c:\SQLEXPR_x86_ENU\ to update the original files.

    Step 7 : Change PCUSOURCE=".\PCUSOURCE" by PCUSOURCE="C:\SQLEXPR_x86_ENU\PCU\pcusource" inside defaultsetup.ini at the following locations: c:\SQLEXPR_x86_ENU\x86\defaultsetup.ini.

    Step 8 : Then I run setup.exe

    I got the issue : 287825 : SQL Server Setup failure 0x84B40000- The folder you specified is not valid for PCUSOURCE input setting. Specify a valid folder.


    Michel Degremont. http://blogs.technet.com/mdegre
    Thursday, August 27, 2009 8:19 PM
  • But you can't deploy the slipstream drop via the command line, in a nice self extracting executable, like you can with the original download...can you?
    Tuesday, February 9, 2010 4:24 AM
  • I hope Microsoft will release the self extracting for SQL Server 2008 SP1 without having to build up a slipstream or similar. I'm having several difficulties in installing it on Windows 7 machines (I've tried differente editions).

    La forma en que Microsoft está distribuyendo el SQL Server 2008 SP1 (cualquiera de las ediciones) deja mucho que desear.,.

    Monday, April 19, 2010 2:32 PM
  • I got the issue : 287825 : SQL Server Setup failure 0x84B40000- The folder you specified is not valid for PCUSOURCE input setting. Specify a valid folder .


    Michel Degremont. http://blogs.technet.com/mdegref
    i assume that you have copy -paste the command lines (like i did ) from the instructions instead of writing them self?! To fix that problem simply replace quotation marks at the PCUSOURCE=".\PCU" line manualy. The quotation marks which were used in the instructions are not quotation-marks and that is the reason why the installer can not recognize the install-path.

    hope i could help..
    • Proposed as answer by TurgayTurk Wednesday, April 21, 2010 9:28 PM
    Wednesday, April 21, 2010 9:27 PM