locked
SharePoint Blog on Homepage (error displaying post) RRS feed

  • Question

  • Hi all,

    I added the SharePoint blog function on our SharePoint online homepage (team site). I used javascript to add the blog, found in the following link:

    https://sharepoint.stackexchange.com/questions/195922/how-to-add-a-blog-to-a-team-site

    The blog function shows and I can add news posts, editing a post is also possible.

    When I try to display a post I get an error page:

    The maximum number of Web Parts for all zones on this page has been exceeded.

    The display page for the posts is just the default ViewPost.asmx, I did not add anything to it.

    Any ideas on how to get the posts to display? Thanks in advance!


    Monday, February 26, 2018 8:04 PM

Answers

All replies

  • Hi Eduard

    the default value of the property MaxZoneParts is 50 ,this property value specify the total number of WebParts allowed in WebPart zone at web part page , this setting is available in the web config of the web application , i think the same value also applied on the SharePoint online , quick workaround to overcome this issue is opening the webparts maintenance page and remove the webparts which aren't needed or less needed . 

    Have a look please on this blog 

    http://icansharepoint.com/completely-deleting-web-parts-on-a-sharepoint-page/

    i hope this will help you


    Best Regrads, Ahmed Madany MCTS @twitter http://twitter.com/ahmed_madany @Blog http://ahmedmadany.wordpress.com @LinkedIn http://eg.linkedin.com/pub/ahmed-madany/35/80/2b6

    Monday, February 26, 2018 8:36 PM
  • Hey

    In your page, just add "?contents=1" suffix after URL .aspx.

    Then you can see the webparts in this page.


    Justin Liu Office Servers and Services MVP, MCSE
    Senior Software Engineer
    Please Vote and Mark as Answer if it helps you.

    Tuesday, February 27, 2018 2:25 AM
  • Hi Eduard Tiggers,

    To add blog in a team site in SharePoint online, you could enable the BlogContent feature in SharePoint online by PnP PowerShell command below.

    Connect-PnPOnline -Url https://site.sharepoint.com/sites/site/ -Credentials (Get-Credential)
    
    Enable-PnPFeature -Identity "{0d1c50f7-0309-431c-ADFB-b777d5473a65}"

    After activating the feature, you will have the Posts list in team site. And you also can use the blog tools web part to create posts.

    You can download the PnP PowerShell command from the link below.

    https://github.com/SharePoint/PnP-PowerShell/releases

    And install PnP PowerShell command according to the article below/

    Office 365 Patterns and Practices PowerShell Commands.

    www.itprotoday.com/skype-business/office-365-patterns-and-practices-powershell-commands

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.



    • Edited by Sara Fan Tuesday, February 27, 2018 7:17 AM
    Tuesday, February 27, 2018 7:17 AM
  • Hi Eduard

    the default value of the property MaxZoneParts is 50 ,this property value specify the total number of WebParts allowed in WebPart zone at web part page , this setting is available in the web config of the web application , i think the same value also applied on the SharePoint online , quick workaround to overcome this issue is opening the webparts maintenance page and remove the webparts which aren't needed or less needed . 

    Have a look please on this blog 

    http://icansharepoint.com/completely-deleting-web-parts-on-a-sharepoint-page/

    i hope this will help you


    Best Regrads, Ahmed Madany MCTS @twitter http://twitter.com/ahmed_madany @Blog http://ahmedmadany.wordpress.com @LinkedIn http://eg.linkedin.com/pub/ahmed-madany/35/80/2b6

    Hi Ahmed,

    Thanks for the tip but the page doesn't even load up in the maintenance mode. It tells me:

    Only Content controls are allowed directly in a content page that contains Content controls.

    Even opening the page 'Post.aspx' in SharePoint designer gives me the error about to many webparts. 

    @Sara Fan, thanks for the detailed description. The Javascript I ran was able to create the lists en make the blog available. The problem is 'only' that a single post cannot be displayed by the post.aspx page because of to many webparts.

    I tried the powershell commands but it did not change anything. I am unable to remove the created lists so I cannot start over. As this is the root team site I also can't just recreate the site :(

    As the issue seems to be with a broken post.aspx page I created a blog subsite and copied the post.aspx to the team site but that gives the error that it points to a non existing list.

    Thursday, March 1, 2018 12:41 AM
  • Hi Eduard Tiggers,

    In SharePoint online, we cannot resolve the error “The maximum number of Web Parts for all zones on this page has been exceeded.”, because we cannot modify the web.config file in SharePoint online.

    So, you could create a new post page and use other methods to create and display posts.

    You could refer to the articles below.

    Create and delete posts and retrieve the social feed by using the JavaScript object model in SharePoint.

    https://docs.microsoft.com/en-us/sharepoint/dev/general-development/how-to-create-and-delete-posts-and-retrieve-the-social-feed-by-using-the-javascr

    SharePoint Online: Retrieve list items from SharePoint list using JavaScript Object Model (JSOM).

    https://social.technet.microsoft.com/wiki/contents/articles/37536.sharepoint-online-retrieve-list-items-from-sharepoint-list-using-javascript-object-model-jsom.aspx

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, March 2, 2018 9:01 AM

  • Hi Eduard Tiggers,

    If the reply is helpful to you, you could mark the reply as answer. Thanks for your understanding.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, March 5, 2018 1:19 AM