locked
People Picker Issue RRS feed

  • Question

  • Hello, 

    I'm using 'People Picker Control' to give access to user.

    but for particular identity i'm facing issue. people picker control not showing any suggestion or message like 'No result found'

    please find follows screen shots.

    when i enter any wrong text it gives at least 'No Result found'.

    i tried follows thing but still not working for particular identity.

    1) I tested this user is present in active directory (result: user is present in active directory).

    2) Sync active directory for this identity (result: synchronization is complete).

    3) Tested user is present in domain with 'net user /domain' using power shell (result: user is present.)

    4) Tested user is present in share point context using ensure user operation using CSOM .

    If any one is knowing this issue please help here. or suggest any thing if i miss something to configure other than this.

     

    Monday, December 28, 2015 1:47 PM

Answers

  • Hi,

    First can you check this in different browser and also by changing the browser compatibility mode to 32 bit?

    Secondly the issue may be related with User Information list as SharePoint stores user information in the UIL to extract data when this user is being searched by the people picker, the people picker extracts information from multiple locations:

    – The User Information List – Active Directory

    The people picker does not extract information from the User Profile Service Application (UPSA). The UPSA syncs information from the AD and updates the UIL, so here can you check the user details what is stored in User Information List as you already confirmed that in Active directory it is correct.

    http://siteurl/_catalogs/users/detail.aspx

    In the below  abcDomainName\pqrUserLoginId ---> abc is the domain and pqr is the user login.

    $web=Get-SPWeb ...web URL...

    $web|Set-SPUser -identity "abcDomainName\pqrUserLoginId" -SyncFromAD


    KRISHANA KUMAR

    SharePoint Architect

    Mosstechnet-kk.com

     

    Please click "Mark As Answer" if this post solves your problem or "Vote As Helpful" if it was useful

    Monday, December 28, 2015 8:29 PM

All replies

  • Hi Chafekar,

    Could you run the below PS script and tell me what is returned? Should be empty if it's the correct path:

    PS C:\> $site = get-spsite http://yoursite.com
    PS C:\> $site.UserAccountDirectoryPath


    • Edited by Sonny Thai Monday, December 28, 2015 7:47 PM
    Monday, December 28, 2015 7:46 PM
  • Hi,

    First can you check this in different browser and also by changing the browser compatibility mode to 32 bit?

    Secondly the issue may be related with User Information list as SharePoint stores user information in the UIL to extract data when this user is being searched by the people picker, the people picker extracts information from multiple locations:

    – The User Information List – Active Directory

    The people picker does not extract information from the User Profile Service Application (UPSA). The UPSA syncs information from the AD and updates the UIL, so here can you check the user details what is stored in User Information List as you already confirmed that in Active directory it is correct.

    http://siteurl/_catalogs/users/detail.aspx

    In the below  abcDomainName\pqrUserLoginId ---> abc is the domain and pqr is the user login.

    $web=Get-SPWeb ...web URL...

    $web|Set-SPUser -identity "abcDomainName\pqrUserLoginId" -SyncFromAD


    KRISHANA KUMAR

    SharePoint Architect

    Mosstechnet-kk.com

     

    Please click "Mark As Answer" if this post solves your problem or "Vote As Helpful" if it was useful

    Monday, December 28, 2015 8:29 PM
  • ya its return empty
    Tuesday, December 29, 2015 5:44 AM
  • Hello,

    i tried this one also but still same issue with id.

    Tuesday, December 29, 2015 5:45 AM
  • Hi,

    Did you try to change the master page to default master page as well to test the case if it is branding related ?


    KRISHANA KUMAR

    SharePoint Architect

    Mosstechnet-kk.com

     

    Please click "Mark As Answer" if this post solves your problem or "Vote As Helpful" if it was useful

    Tuesday, December 29, 2015 5:33 PM
  • Hello,

    i tried OOTB default master page. but still id is not suggest anything in People Picker. at least expected 'No result found'

    Wednesday, December 30, 2015 6:55 AM
  • Hi,

    Next option you can try to delete the user from User Information List and run the user profile sync to bring the user details again in User Information List and check.


    KRISHANA KUMAR

    SharePoint Architect

    Mosstechnet-kk.com

     

    Please click "Mark As Answer" if this post solves your problem or "Vote As Helpful" if it was useful

    Thursday, December 31, 2015 4:21 PM