System.IO.FileNotFoundException: Could not load file or assembly '' RRS feed

  • Question

  • Hi,


    Im having some problem with one of my ASP .Net projects?


    First som background:

    I had one solution "A" and needed a hole new solution "B", wich was a copy of solution "A". I've renamed the project, made a new guid and so on.


    Now when i open visual studio, i can run and debug solution "B".

    But when i try to run og debug solution "A" i get following error:

    System.IO.FileNotFoundException: Could not load file or assembly 'B.dll' or one of its dependencies.


    Why is solution "A" pointing at solution "B"'s dll-file? And how do i fix this.


    This error only orrucs on one of the computers, and that computer is the one that i've made the copy on.



    Tuesday, February 12, 2008 12:04 PM

All replies

  • I guess you could always open the project files in notepad and do a search for the old assembly name.  In all likelihood it's in there somewhere.

    Wednesday, February 13, 2008 6:54 PM
  • Hi Paul,


    Thanks for replying.


    But it's the original solution im getting this error from. Not the copy-solution "B", it works fine. So there is no point of searching..


    I have also tried empty .net temp folder. And copied a new version from the server. So i don't think it's in the solution-files? I'm thinking more like something has an old reference in the Visual Studio or IIS.. Because i can compile the code on my computer, copy it to the server and all is running. -But the server is not running both web-project (only "A", the one i can't run/debug localy, but apparently compile and use) 


    -i will not try to copy the other project to server, just to to see if it could Smile

    Wednesday, February 13, 2008 10:26 PM
  • To troubleshoot this issue, we really need the source code and the detailed repro steps to reproduce the problem, so that we can investigate the issue in house. It is not necessary that you send out the complete source of your project. We just need a simplest sample to reproduce the problem. You can remove any confidential information or business logic from it.

    You can send a sample project and repro steps in details to may email address which can be found in my personal profile page.

    Thursday, February 14, 2008 5:22 AM
  • Hi Feng,


    yes, but again, i don't think it's the sourcecode. It can be compiled and used on the server. And the solution also works fine on a other developermachine. So i belive that you have to look at the computer Smile...

    Unfortunly it's my computer at work, so i can't do so much. And it's a rather big solution, so i have to spent hours stripping out the code. And even if i did that, you can't use it, because we also use EPIserver and NetStar, wich are licensed software. And it will not run without thise extensions.


    So i think i will try to get the it-department to reinstall visual studio? Sad

    Thursday, February 14, 2008 12:19 PM
  • Hi again Feng,


    The reinstallation is taking some time, so i have looked a littel further and trying to make a sampel for you. But visual studio stalls every time i tries to remove my reffences?? I tried to let it be in over night (removing reffences), no result?


    But i've been looking in the file "[project.csproj]" and saw that the "FlavorProperties-guid" is the same in both projects? I've earlyer changed the guid in the project, but it has't been changed in the file?

    <FlavorProperties GUID="{349c5851-65df-11da-9384-00065b846f21}">


    Can i mannuel change that or how do i do that?..


    If you want i can mail you the .csproj/.sln/.suo from both projects?


    Tanks for you help

    Wednesday, February 20, 2008 8:59 AM