none
Release Build is not working RRS feed

  • Question

  • Hi all,

    I'm using VS 2010 Pro Sp1.

    When building a single C# project and change it's build configuration to Release (right clicking the project), and then build the project (no Release bin is created) But, it revert back to Debug. However, when work with a solution (multi-project) and right clicking the solution enter and selecting Release... it works fine.

    How can I create a release build with a single project?


    King Coffee

    Monday, September 9, 2013 9:16 PM

All replies

  • Hi King,

    Thanks for your posting.

    From your description,  I know that “ when building a single C# project and change it build configuration to Release ,then build the project (no Release bin is created), but it revert back to Debug “. I think you can check  the configuration option and output path :

    In addition , if you want to  create a release build ,please  refer “Walkthrough: Building an Application” that introduces how to create a release build  .

    Hope these help.


    Lilia Gong <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.


    Tuesday, September 10, 2013 1:55 PM
    Moderator
  • Hi Lilia,

    The link “Walkthrough: Building an Application” is not working properly.

    When I select Release... the output does change to bin/Release. But when I build the project, it changes back to debug. This might be a IDE flaw. The project was originally a vs2008 and auto-updated to 2010.

    I will try to create a vs 2010 project and then add the source files.

    Thanks,

    King


    King Coffee

    Thursday, September 12, 2013 10:29 PM
  • The problem is: the IDE is not saving the changes. When I make it "Rlease"and save it... and then immediately reopen it. The contain was not saved or revert back to debug.

    My workaround is to add a empty project and set the configuration the Release via the solution properties. It apprears to be a default phantom solution config setup. 

    This is definitely a IDE bug in VS 2010 pro.


    King Coffee


    • Edited by King Coffee Friday, November 1, 2013 9:47 AM
    Thursday, September 12, 2013 11:43 PM
  • Hi King ,

    Thanks for your reply.

    Please  try to use devenv.exe/ResetSettings  to Restore Visual Studio to default settings.

    To troubleshoot this issue ,Could you help me to check this issue will occur  if  updating   Visual Stduio  2010 SP1  or testing on another machine ?

    If my above suggestion can't  still resolve this issue , please  contact  connect site: https://connect.microsoft.com/

    In addition, I have modified  Walkthrough: Building an Application, you can try to check again.

    Hope these help.


    Lilia Gong <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.


    Wednesday, September 18, 2013 3:44 AM
    Moderator
  • Resetting devenv did not work.

    But I noticed, the projects architecture for creating a project is different in Windows 7 64bit Pro and  Ultimate.  With Pro, A default solution is generated with one project. But with Ultimate, the solution tag is missing in the Solution Explorer box. You need the solution config box to toggle the project build mode.


    King Coffee



    • Edited by King Coffee Wednesday, September 18, 2013 8:50 PM
    Wednesday, September 18, 2013 8:10 PM