locked
Sharepoint 2010 - Web Part URL re-directing RRS feed

  • Question

  • All,

    In SharePoint 2010, I added a web part in the page viewer for changing passwords. For the web part, I specified a link: "https://blah/blah/. When I hit OK after entering the password information to change, I get the following message "Do you want to view only the webpage content that was delivered securely". I entered in a secure site, so why am I receiving a Security Warning (First Question). (Second Question) When I hit OK, the web part disappears. If I do this outside of SharePoint, I noticed that the URL re-directs to a different URL looking for the next asp file. I do have re-direction for my home site. Is there anyway to stop the re-direction for the web part only? Any ideas would be much appreciated. [Under the gun to get this done :-( ]

    Using IIS7, SharePoint 2010 and Windows Server 2008

    Thursday, June 7, 2012 8:56 PM

Answers

  • Hi SP_Rookie,

    So what you are seeing is actually IE functionality in terms of security purposes. This is a common message if the site you access using IE where the content being returned has both HTTP and HTTPS url being sent back to the browser. To confirm this you could download a sniffer program such as HTTPWatch or Fiddler to capture they internet traffic and determine the URLs that are being sent in the request.

    To fix this issue with the browser message

    Display Mixed Content. go to Tools -> Internet Options--> select the Security tab-->Highlight “Internet” zone--> click the “Custom Level” button. Scroll-down the list of options and set the “Display mixed content” setting from “Prompt” to “Enable.”

    Please note this message is intended for security purposes and recommended to usually leave this enabled however that is your organization's call. You could roll this IE setting out to any machine within your domain, however any machines not on your domain they would receive this prompt.

    http://blogs.msdn.com/b/askie/archive/2009/05/14/mixed-content-and-internet-explorer-8-0.aspx
    http://msdn.microsoft.com/en-us/library/ee264315(v=VS.85).aspx

    Let me know if this information assists you!

    Thanks!

     


    Adam Rudell | Technical Support Lead | SharePoint Technologies | Microsoft Corporation

    • Marked as answer by Emir Liu Thursday, June 14, 2012 8:14 AM
    Friday, June 8, 2012 4:32 PM
  • More than likely you have some HTTP being displayed to the user on the HTTPS site, such as an image file. If you capture a trace using HTTPWatch or Fiddler you should be able to determine the location of where the content is coming from.


    Adam Rudell | Technical Support Lead | SharePoint Technologies | Microsoft Corporation

    • Marked as answer by Emir Liu Thursday, June 14, 2012 8:14 AM
    Monday, June 11, 2012 3:57 PM

All replies

  • Hi,

    Thank you for your post.

    I'm trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thanks & Regards,
    Emir


    Emir Liu

    TechNet Community Support

    Friday, June 8, 2012 1:02 PM
  • Hi SP_Rookie,

    So what you are seeing is actually IE functionality in terms of security purposes. This is a common message if the site you access using IE where the content being returned has both HTTP and HTTPS url being sent back to the browser. To confirm this you could download a sniffer program such as HTTPWatch or Fiddler to capture they internet traffic and determine the URLs that are being sent in the request.

    To fix this issue with the browser message

    Display Mixed Content. go to Tools -> Internet Options--> select the Security tab-->Highlight “Internet” zone--> click the “Custom Level” button. Scroll-down the list of options and set the “Display mixed content” setting from “Prompt” to “Enable.”

    Please note this message is intended for security purposes and recommended to usually leave this enabled however that is your organization's call. You could roll this IE setting out to any machine within your domain, however any machines not on your domain they would receive this prompt.

    http://blogs.msdn.com/b/askie/archive/2009/05/14/mixed-content-and-internet-explorer-8-0.aspx
    http://msdn.microsoft.com/en-us/library/ee264315(v=VS.85).aspx

    Let me know if this information assists you!

    Thanks!

     


    Adam Rudell | Technical Support Lead | SharePoint Technologies | Microsoft Corporation

    • Marked as answer by Emir Liu Thursday, June 14, 2012 8:14 AM
    Friday, June 8, 2012 4:32 PM
  • Yes, your reply and the link are both helpful. However,  it is puzzling that I am getting the message when this is a HTTPS secure site. My bigger issue is determining why this message is displaying in the first place. This will not be satisfactory to the user for changing passwords. 

    SP_Rookie

    Monday, June 11, 2012 3:36 PM
  • More than likely you have some HTTP being displayed to the user on the HTTPS site, such as an image file. If you capture a trace using HTTPWatch or Fiddler you should be able to determine the location of where the content is coming from.


    Adam Rudell | Technical Support Lead | SharePoint Technologies | Microsoft Corporation

    • Marked as answer by Emir Liu Thursday, June 14, 2012 8:14 AM
    Monday, June 11, 2012 3:57 PM