locked
Why access denied (80070005) when I run Metro Simple bluetooth LE Controller using TICC2540 Dev kit in Win8 release preview

    Question

  • I have already tried to run Simple key service Metro with TICC2540 bluetooth accessory in Win8 

    Consomer Preview, and it is successful. 

    Now, I'll like to verify in Win8 RC.

    First, I use BTLE GATT Profile Drivers from MSDN to update WPD driver as I did in Win8 Consomer 

    Preview.

    Then I run Metro Simple bluetooth LE Controller using TICC2540 Dev kit, it show error message "Getting 

    the device failed with error : 80070005"  on output display. 

    Is there any step I have to do before run Metro in Win8 RC?

    I have also tried to create new device metadata package in Visual studio RC before update driver 

    according to http://social.msdn.microsoft.com/Forums/pl-PL/tailoringappsfordevices/thread/e07ee975-

    c86b-48e1-a829-5f755efae715.

    But the problem still exists.

    I have two question about how to create device metadata package.

    1.which category I have to choose for simple key service?

    2.Should I do any step after finishing create device metadata package?

    ps.  My hardwareID : BTHLEDevice\{0000ffe0-0000-1000-8000-00805f9b34fb}_Dev_VID&01000d_PID&0000_REV&0110

    Thanks!!!!

    Wednesday, July 04, 2012 2:42 AM

Answers

All replies

  • ACCESS_DENIED means that the correct device metadata is not installed. Only after the correct driver and metadata are installed will the app be able to function.

    Device Metadata needs to be written using the Device Metadata Authoring Wizard :

    http://msdn.microsoft.com/en-us/library/windows/hardware/hh454826(v=vs.85).aspx

    Wednesday, July 04, 2012 7:21 AM
    Moderator
  • Hello,

    I have the same "80070005" error. I followed the instruction of Device Metadata Authoring Wizard but without success. :(

    Can anybody describe the right procedure to get the right value for Associations (Hardware-ID/Model-ID) and Applications?
    Where I have to install the Device Metadata Package, in the BLE Generic Attribute (GATT) Profile Drivers or in the Bluetooth Low Energy Health Profiles sample?

    Sorry, I'm really new in Windows-programming.

    I use a x64 AMD System so I have disable the digitaly signed driver Option.

    Can you tell me what am I doing wrong?

    Andy


    Edit: In addition, I try the Health Heart Rate Samples too but the same error "80070005" again.
    • Edited by DonAlbe Monday, October 29, 2012 1:34 PM
    Monday, October 29, 2012 1:21 PM