none
WCF-SAP adapter -Biztalk 2013 R2 issues RRS feed

  • Question

  • Hello people,

    Got a query regarding sap adapter in BT 2013 R2. We have got 2biztalk servers on PROD and getting below warnings logged in event log in 2nd server at specific time and then after 5mins the messages are processed and delivered to SAP system.

    The issue is when the messages arrived in biztalk at certain time then below warnings  are logged and WE ASSUME messages are not sent to SAP but in reality the messages are already sent to SAP even with these warnings and later after 5mins interval the messages are actually sent out by biztalk but these messages are errored out in SAP  with message as document is already posted .. which means the messages were already in SAP. THIS is bit weird looks like. 

    The adapter failed to transmit message going to send port "" with URL "sap://CLIENT=;LANG=EN;@a//?GWHOST=&GWSERV=&ListenerGwServ=&ListenerGwHost=&RfcSdkTrace=False&AbapDebug=False". It will be retransmitted after the retry interval specified for this Send Port. Details:"Unknown Error Description ".

    Can someone please advise what this error mean? and when there were warnings IS THERE POSSIBILITY THAT MESSAGES ARE SENT TO sap? Please suggest as what might be going on in this scenario. Thank you. 

    Kind Regards

    Friday, November 17, 2017 4:53 PM

All replies

  • Hello people,

    Got a query regarding sap adapter in BT 2013 R2. We have got 2biztalk servers on PROD and getting below warnings logged in event log in 2nd server at specific time and then after 5mins the messages are processed and delivered to SAP system.

    The issue is when the messages arrived in biztalk at certain time then below warnings  are logged and WE ASSUME messages are not sent to SAP but in reality the messages are already sent to SAP even with these warnings and later after 5mins interval the messages are actually sent out by biztalk but these messages are errored out in SAP  with message as document is already posted .. which means the messages were already in SAP. THIS is bit weird looks like. 

    The adapter failed to transmit message going to send port "" with URL "sap://CLIENT=;LANG=EN;@a//?GWHOST=&GWSERV=&ListenerGwServ=&ListenerGwHost=&RfcSdkTrace=False&AbapDebug=False". It will be retransmitted after the retry interval specified for this Send Port. Details:"Unknown Error Description ".

    Can someone please advise what this error mean? and when there were warnings IS THERE POSSIBILITY THAT MESSAGES ARE SENT TO sap? Please suggest as what might be going on in this scenario. Thank you. 

    Kind Regards

    This MICROSOFT HOTFIX is probably what you need.

    Here is also a good MSDN article on sending IDOCS to SAP:

    Send IDOCs to SAP using BizTalk Server

    If the HOTFIX doesn't help I would check for connectivity related issue: Firewalls, RPC configuration, etc 


    My Technet Articles

    If you like this or another reply, vote it up!
    If you think this or another reply answers the original question, mark it or propose it as an answer.


    Mauricio Feijo
    www.mauriciofeijo.com



    Friday, November 17, 2017 8:26 PM
  • Hi Feijo,

    thanks for responding. I tried to check on that latest hotfix but it shows up nothing  there. Anyway thanks for suggesting and I am still looking for the resolution.

    Wednesday, March 28, 2018 12:52 PM
  • Hi Feijo,

    thanks for responding. I tried to check on that latest hotfix but it shows up nothing  there. Anyway thanks for suggesting and I am still looking for the resolution.

    Hi Yashod,

    When you say "shows up nothing there", do you mean you could not download the hotfix? Or do you mean you installed it and it didn't change the behavior?

    This is the actual link to the hotfix:

    FIX: You receive a "The adapter failed to transmit message going to send port" error message in the BizTalk Adapter 2.0 for mySAP Business Suite


    My Technet Articles

    If you like this or another reply, vote it up!
    If you think this or another reply answers the original question, mark it or propose it as an answer.


    Mauricio Feijo
    www.mauriciofeijo.com

    Thursday, March 29, 2018 12:49 PM