none
Deploying WCF 4.5 to a test server RRS feed

  • Question

  • This is probably the 5 millionth deployment question, but I need an answer that even I can understand.  There are apparently 8000 options for doing this, but the only one that "works" for me doesn't seem to do anything.

    I'm working in WCF 4.5 and want to deploy this service to a web server using IIS 7.0 (we're not allowed to have IIS on our laptops so I can't host it in IIS locally).

    My service is called COREServices, and there is a .svc file in my folder.  Under Build > Configuration Manager I have Project: COREServices and Configuration: Release and Any CPU everywhere.

    In my Project > Properties I have Build > Output Path: web server name\c$\inetpub\coreservices which is the folder I want my stuff to go.  When I build the project, something goes to that folder, but it's just COREServices.dll, COREServices.pdb and an empty web.config file.  The web server doesn't seem to be able to make heads or tails of this, nor I. 

    Under Package/Publish Web I have Location where package will be created: COREServices.zip in the above folder, but no zip file gets created there after building.  For IIS Web site I have: Default Web Site/COREServices, but I created that manually as the build didn't do it for me.

    Speaking of creating Default Web Site/COREServices manually, very little looks familiar from my past experience with former service deployment.  I created a new app pool and added it to the virtual directory, but there's no way to set the permissions of the app pool to the app folder, as the instructions there tell me to do:

    "The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that <domain>\<computer_name>$ has Read access to the physical path. Then test these settings again."

    I noticed that under BUILD there is a "Publish Selection" option, but the prompts are unintelligible to me.  I recall in the past I could create a deployment profile, but although there is a Manage Profiles button, clicking it doesn't allow me to manage anything - everything is disabled.

    In short, I'm totally confused and need some kind soul to walk me through this.

    Thanks!!!

    Friday, November 22, 2013 8:03 PM

Answers

  • Hi,

    Maybe you can try to use WebDeploy to publish the WCF service to remote server, then you need install it on IIS. Please tyr to follow the tutorial to deploy the service.

    http://learn.iis.net/page.aspx/426/overview-of-web-deploy/

    And you have other options to publish the WCF service to remote server, use plug-in functionality, One-Click Publish, etc. And I'd suggest you take a look at the suggestion in this thread.

    http://forums.iis.net/t/1187686.aspx/1.

    Best Regards,
    Amy Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, November 27, 2013 10:35 AM
    Moderator